Moodle - Updating to HTTPS without Updating config.php means Users Cannot Login

I’ve screwed up. I tried the 2nd option when installing with certbot --apache (force https) and now I’ve locked myself out of the Moodle site’s admin login – also can’t see normal graphics, etc. (I still have access via terminal login to the server, but I can’t do anything with Moodle.) Is there any way to restore this site to the pre-letsencrypt install state? I’ve tried reinstalling using option 1 (easy) only, but hasn’t restored my site to a usable state. I didn’t have any trouble installing ssl (and it tested well on various sites) but my browsers still showed as unsecure (which is why I tried the 2nd option).

Thanks for any pointers.

Should add … I’m using Ubuntu 16.04 on Digital Ocean. This is my first server (and probably my last) and everything’s gone fairly well up to this point (following lots of instructions). My wife is using Moodle 3.2 (don’t know if that part matters).

Turns out it wasn’t necessary – I just had to set line in one of my config files (config.php) from $CFG->wwwroot = 'http:// … to $CFG->wwwroot ='https// …

All good now. Web site is secure – and showing so in my web browsers. Thank you

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.