Mongodb error when trying to run letsencrypt-auto


#1

Please fill out the fields below so we can help you better.

My domain is:
draft.speechi.net

I ran this command:
letsencrypt-auto

It produced this output:
Bootstrapping dependencies for Debian-based OSes…
Get:1 security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Hit:2 ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial InRelease
Get:3 ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Get:4 ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]
Get:5 ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/main Sources [237 kB]
Get:6 ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/restricted Sources [2996 B]
Get:7 ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [496 kB]
Get:8 ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/main i386 Packages [486 kB]
Get:9 ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages [7776 B]
Get:10 ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/restricted i386 Packages [7792 B]
Get:11 ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/restricted Translation-en [2548 B]
Get:12 ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages [440 kB]
Get:13 ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/universe i386 Packages [430 kB]
Get:14 ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/multiverse amd64 Packages [8652 B]
Get:15 ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/multiverse i386 Packages [7452 B]
Fetched 2433 kB in 0s (4427 kB/s)
Reading package lists… Done
Reading package lists… Done
Building dependency tree
Reading state information… Done
ca-certificates is already the newest version (20160104ubuntu1).
gcc is already the newest version (4:5.3.1-1ubuntu1).
libffi-dev is already the newest version (3.2.1-4).
python is already the newest version (2.7.11-1).
python set to manually installed.
The following packages were automatically installed and are no longer required:
python-acme python-cffi-backend python-chardet python-configargparse python-configobj python-cryptography python-dialog python-enum34 python-funcsigs python-idna
python-ipaddress python-letsencrypt python-mock python-ndg-httpsclient python-openssl python-parsedatetime python-pbr python-psutil python-pyasn1 python-pyicu python-requests
python-rfc3339 python-six python-tz python-urllib3 python-zope.component python-zope.event python-zope.hookable python-zope.interface
Use ‘sudo apt autoremove’ to remove them.
The following additional packages will be installed:
libpython-dev libpython2.7 libpython2.7-dev libpython2.7-minimal libpython2.7-stdlib libssl1.0.0 python-pip-whl python2.7 python2.7-dev python2.7-minimal python3-virtualenv
Suggested packages:
augeas-doc augeas-tools python2.7-doc binfmt-support
Recommended packages:
libssl-doc
The following NEW packages will be installed:
augeas-lenses libaugeas0 libpython-dev libpython2.7-dev python-dev python-pip-whl python-virtualenv python2.7-dev python3-virtualenv virtualenv
The following packages will be upgraded:
libpython2.7 libpython2.7-minimal libpython2.7-stdlib libssl-dev libssl1.0.0 openssl python2.7 python2.7-minimal
8 upgraded, 10 newly installed, 0 to remove and 270 not upgraded.
2 not fully installed or removed.
Need to get 37.4 MB of archives.
After this operation, 44.7 MB of additional disk space will be used.
Get:1 http://ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/main amd64 libssl-dev amd64 1.0.2g-1ubuntu4.6 [1344 kB]
Get:2 http://ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/main amd64 libssl1.0.0 amd64 1.0.2g-1ubuntu4.6 [1082 kB]
Get:3 http://ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/main amd64 python2.7 amd64 2.7.12-1ubuntu0~16.04.1 [224 kB]
Get:4 http://ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/main amd64 libpython2.7 amd64 2.7.12-1ubuntu0~16.04.1 [1070 kB]
Get:5 http://ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/main amd64 libpython2.7-stdlib amd64 2.7.12-1ubuntu0~16.04.1 [1884 kB]
Get:6 http://ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/main amd64 python2.7-minimal amd64 2.7.12-1ubuntu0~16.04.1 [1295 kB]
Get:7 http://ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/main amd64 libpython2.7-minimal amd64 2.7.12-1ubuntu0~16.04.1 [339 kB]
Get:8 http://ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/main amd64 openssl amd64 1.0.2g-1ubuntu4.6 [492 kB]
Get:9 http://ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial/main amd64 augeas-lenses all 1.4.0-0ubuntu1 [263 kB]
Get:10 http://ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial/main amd64 libaugeas0 amd64 1.4.0-0ubuntu1 [154 kB]
Get:11 http://ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/main amd64 libpython2.7-dev amd64 2.7.12-1ubuntu0~16.04.1 [27.8 MB]
Get:12 http://ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial/main amd64 libpython-dev amd64 2.7.11-1 [7728 B]
Get:13 http://ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/main amd64 python2.7-dev amd64 2.7.12-1ubuntu0~16.04.1 [276 kB]
Get:14 http://ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial/main amd64 python-dev amd64 2.7.11-1 [1160 B]
Get:15 http://ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/universe amd64 python-pip-whl all 8.1.1-2ubuntu0.4 [1110 kB]
Get:16 http://ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/universe amd64 python-virtualenv all 15.0.1+ds-3ubuntu1 [46.6 kB]
Get:17 http://ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/universe amd64 python3-virtualenv all 15.0.1+ds-3ubuntu1 [43.2 kB]
Get:18 http://ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/universe amd64 virtualenv all 15.0.1+ds-3ubuntu1 [4342 B]
Fetched 37.4 MB in 1s (25.5 MB/s)
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = “UTF-8”,
LANG = "en_GB.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to a fallback locale (“en_GB.UTF-8”).
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Preconfiguring packages …
(Reading database … 64111 files and directories currently installed.)
Preparing to unpack …/libssl-dev_1.0.2g-1ubuntu4.6_amd64.deb …
Unpacking libssl-dev:amd64 (1.0.2g-1ubuntu4.6) over (1.0.2g-1ubuntu4.1) …
Preparing to unpack …/libssl1.0.0_1.0.2g-1ubuntu4.6_amd64.deb …
Unpacking libssl1.0.0:amd64 (1.0.2g-1ubuntu4.6) over (1.0.2g-1ubuntu4.1) …
Preparing to unpack …/python2.7_2.7.12-1ubuntu0~16.04.1_amd64.deb …
Unpacking python2.7 (2.7.12-1ubuntu0~16.04.1) over (2.7.11-7ubuntu1) …
Preparing to unpack …/libpython2.7_2.7.12-1ubuntu0~16.04.1_amd64.deb …
Unpacking libpython2.7:amd64 (2.7.12-1ubuntu0~16.04.1) over (2.7.11-7ubuntu1) …
Preparing to unpack …/libpython2.7-stdlib_2.7.12-1ubuntu0~16.04.1_amd64.deb …
Unpacking libpython2.7-stdlib:amd64 (2.7.12-1ubuntu0~16.04.1) over (2.7.11-7ubuntu1) …
Preparing to unpack …/python2.7-minimal_2.7.12-1ubuntu0~16.04.1_amd64.deb …
Unpacking python2.7-minimal (2.7.12-1ubuntu0~16.04.1) over (2.7.11-7ubuntu1) …
Preparing to unpack …/libpython2.7-minimal_2.7.12-1ubuntu0~16.04.1_amd64.deb …
Unpacking libpython2.7-minimal:amd64 (2.7.12-1ubuntu0~16.04.1) over (2.7.11-7ubuntu1) …
Preparing to unpack …/openssl_1.0.2g-1ubuntu4.6_amd64.deb …
Unpacking openssl (1.0.2g-1ubuntu4.6) over (1.0.2g-1ubuntu4.1) …
Selecting previously unselected package augeas-lenses.
Preparing to unpack …/augeas-lenses_1.4.0-0ubuntu1_all.deb …
Unpacking augeas-lenses (1.4.0-0ubuntu1) …
Selecting previously unselected package libaugeas0.
Preparing to unpack …/libaugeas0_1.4.0-0ubuntu1_amd64.deb …
Unpacking libaugeas0 (1.4.0-0ubuntu1) …
Selecting previously unselected package libpython2.7-dev:amd64.
Preparing to unpack …/libpython2.7-dev_2.7.12-1ubuntu0~16.04.1_amd64.deb …
Unpacking libpython2.7-dev:amd64 (2.7.12-1ubuntu0~16.04.1) …
Selecting previously unselected package libpython-dev:amd64.
Preparing to unpack …/libpython-dev_2.7.11-1_amd64.deb …
Unpacking libpython-dev:amd64 (2.7.11-1) …
Selecting previously unselected package python2.7-dev.
Preparing to unpack …/python2.7-dev_2.7.12-1ubuntu0~16.04.1_amd64.deb …
Unpacking python2.7-dev (2.7.12-1ubuntu0~16.04.1) …
Selecting previously unselected package python-dev.
Preparing to unpack …/python-dev_2.7.11-1_amd64.deb …
Unpacking python-dev (2.7.11-1) …
Selecting previously unselected package python-pip-whl.
Preparing to unpack …/python-pip-whl_8.1.1-2ubuntu0.4_all.deb …
Unpacking python-pip-whl (8.1.1-2ubuntu0.4) …
Selecting previously unselected package python-virtualenv.
Preparing to unpack …/python-virtualenv_15.0.1+ds-3ubuntu1_all.deb …
Unpacking python-virtualenv (15.0.1+ds-3ubuntu1) …
Selecting previously unselected package python3-virtualenv.
Preparing to unpack …/python3-virtualenv_15.0.1+ds-3ubuntu1_all.deb …
Unpacking python3-virtualenv (15.0.1+ds-3ubuntu1) …
Selecting previously unselected package virtualenv.
Preparing to unpack …/virtualenv_15.0.1+ds-3ubuntu1_all.deb …
Unpacking virtualenv (15.0.1+ds-3ubuntu1) …
Processing triggers for libc-bin (2.23-0ubuntu3) …
Processing triggers for mime-support (3.59ubuntu1) …
Processing triggers for man-db (2.7.5-1) …
Setting up libssl1.0.0:amd64 (1.0.2g-1ubuntu4.6) …
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Setting up libssl-dev:amd64 (1.0.2g-1ubuntu4.6) …
Setting up mongodb-server (1:2.6.10-0ubuntu1) …
insserv: warning: script ‘firewall.sh’ missing LSB tags and overrides
insserv: There is a loop between service nginx and firewall.sh if stopped
insserv: loop involving service firewall.sh at depth 2
insserv: loop involving service nginx at depth 1
insserv: Stopping firewall.sh depends on nginx and therefore on system facility `$all’ which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package mongodb-server (–configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of mongodb:
mongodb depends on mongodb-server (>= 1:2.4.1-2); however:
Package mongodb-server is not configured yet.

dpkg: error processing package mongodb (–configure):
dependency problems - leaving unconfigured
Setting up libpython2.7-minimal:amd64 (2.7.12-1ubuntu0~16.04.1) …
No apport report written because the error message indicates its a followup error from a previous failure.
Setting up python2.7-minimal (2.7.12-1ubuntu0~16.04.1) …
Setting up libpython2.7-stdlib:amd64 (2.7.12-1ubuntu0~16.04.1) …
Setting up python2.7 (2.7.12-1ubuntu0~16.04.1) …
Setting up libpython2.7:amd64 (2.7.12-1ubuntu0~16.04.1) …
Setting up openssl (1.0.2g-1ubuntu4.6) …
Setting up augeas-lenses (1.4.0-0ubuntu1) …
Setting up libaugeas0 (1.4.0-0ubuntu1) …
Setting up libpython2.7-dev:amd64 (2.7.12-1ubuntu0~16.04.1) …
Setting up libpython-dev:amd64 (2.7.11-1) …
Setting up python2.7-dev (2.7.12-1ubuntu0~16.04.1) …
Setting up python-dev (2.7.11-1) …
Setting up python-pip-whl (8.1.1-2ubuntu0.4) …
Setting up python-virtualenv (15.0.1+ds-3ubuntu1) …
Setting up python3-virtualenv (15.0.1+ds-3ubuntu1) …
Setting up virtualenv (15.0.1+ds-3ubuntu1) …
Processing triggers for libc-bin (2.23-0ubuntu3) …
Errors were encountered while processing:
mongodb-server
mongodb
E: Sub-process /usr/bin/dpkg returned an error code (1)

My operating system is (include version):
Ubuntu 16.04 LTS

My web server is (include version):
nginx (but I guess it is not important as I will be configuring it manually)

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):
yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no

I will add that I have already installed mongodb for my server and am already using it.


#2

Hi @DukePlumem

Do you have letsencrypt installed currently on the server?

MongoDB is not a dependency for the letsencrypt client as far as I am aware so it’s weird this is causing issues

Andrei


#3

Hi Andrei,

No I have cloned the github repository and run letsencrypt-auto. I did try
installing it with sudo apt-get install letsencrypt but I get the same
error.


#4

Your Debian-based OS is stuck on setting-up the mongodb-server package that you must have installed in the past and failed to configure correctly. This has nothing to do with Let’s Encrypt. Please handle the package-configuration problem with MongoDB separately, then re-try certbot-auto.


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.