Missing acme-challenge. What shall I do?


#1

It came to renew the certificate, but I have somehow managed to remove the directory with acme-challenge. I have no idea how to repair it.

My domain is: phabricator.pbocan.net

I ran this command:
certbot certonly

It produced this output:
`http://phabricator.pbocan.net/.well-known/acme-challenge/F0xGVf2dWppZhgTbk4_PlQQmJiNlJ5noHEK3oBy9W7Y:
"

404 Not Found

404 Not Found


" `

My operating system is (include version): DEBIAN Jessie

My web server is (include version): NGINX/1.6.2

My hosting provider, if applicable, is: NONE.

I can login to a root shell on my machine (yes or no, or I don’t know): yes.

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no.


#2

Can you answer the questions you missed out on the form please. With just your domain and a “404” it’s difficult to give you any useful advice.

What client are you running ?
what command did you run ?
Can you provide the full log please ( with the debug option if the client you’re using supports it).

You’ve edited and added the data - thanks - I will take a look

With certonly ( see the manual ) you need to be giving a little more information - such as webroot ( for where the root files for the domain are) and what domains you want

certbot certonly --webroot -w /var/www/example/ -d www.example.com -d example.com -w /var/www/other -d other.example.net -d another.other.example.net

would obtain a single certificate for all of those names, using the /var/www/example webroot directory for the first two, and /var/www/other for the second two.


#3

I have tried to find acme-challenge on the drive with find tool, but I have somehow fucked up months ago. So the question is, is there any way how to restore the “acme-challenge” directory and data within the folder? (Run command/delete something).


#4

certbot will generate it. however it needs to know where to create it - hence it needs the “webroot” (or apache or nginx and it can read from there )


#5

I have added root directory for that site. However it can not reach the acme-challenge directory from HTTP because there is none.


#6

if you create the “.well-known/acme-challenge” folder in your webroot, and then add a file called “test” at webroot/.well-known/acme-challenge/test and just the plain text contents “success”

can you then reach it in your browser at phabricator.pbocan.net/.well-known/acme-challenge/test ?


#7

Okay, now certbot said that “archive directory exists for phabricator.pbocan.net” … what should I think of it?


#8

I’m confused, I wasn’t asking if you could use certbot, I was resolving the initial issue you had and seeing if you could reach phabricator.pbocan.net/.well-known/acme-challenge/test in your browser. I can’t.


#9

It could not see it. I tweaked the vhost configuration. I ran the certbot aaand this happens…


#10

There’s no need to run certbot yet - that will only confuse things in narrowing down the error.

Have you created the file webroot/.well-known/acme-challenge/test ?

If so, and you can’t reach phabricator.pbocan.net/.well-known/acme-challenge/test in your browser, then there is a configuration or webroot issue with your webserver.


#11

Yes there was that problem. I fixed it.


#12

ok, I still can’t reach phabricator.pbocan.net/.well-known/acme-challenge/test so there is still an issue from the general internet


#13

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.