Mime type not recognized after install certificate

Hi! and Greetings from Chile.

I installed osTicket on a virtual machine running Ubuntu. Before that, I installed a certbot certificate on the empty website.

When I try to see something, it shows the message "The stylesheet https://mesadeayuda.atika.cl/setup/css/wizard.css?e148727 was not loaded because its MIME type, “text/html”, is not “text/css”. in a way, seems that apache or the system itself doesn't recognize css or js files. And that occurs with all websites on the same server.

I try to reinstall apache and certbot but nothing happens.

My domain is mesadeayuda.atika.cl, but you can also see in seguimiento.atika.

I run the command certbot --apache

It produced this output: when I see in the browser console, it shows "The stylesheet http://seguimiento.atika.cl/css/chunk-vendors.a75563b9.css was not loaded because its MIME type, “text/html”, is not “text/css”.

My web server is (include version): Apache2.4.52

The operating system my web server runs on is (include version): Ubuntu 22.04

My hosting provider, if applicable, is: no one: I run in a datacenter

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): Certbot 1.21.0

Thanks in advance for your help!

Welcome @Rodrigo.Moya

That is not a problem with your Let's Encrypt certs. Your server and/or web page is not configured properly. You might check with the osTicket people on what is wrong.

4 Likes