Lightsail wordpress website ssl/tls probems

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:each1teach1.us

I ran this command:https://www.shakzee.com/how-to-install-lets-encrypt-ssl-certificate-on-your-aws-lightsail-instance/ and i get this in ssllabs https://www.ssllabs.com/ssltest/analyze.html?d=each1teach1.us&ignoreMismatch=on&latest

It produced this output: They were all correct I noticed since I changed my dynamic IP to static after the whole process. My problem I am not able to validate TXT record. Therefore my site is not know. i check ssllabs and get this–>> see the pic.

My web server is (include version):wordpress

The operating system my web server runs on is (include version):debian based

My hosting provider, if applicable, is:cirrushosting

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):certbot 0.31.0

I need a way to redo the TXT record verification as when I run this command

/home/bitnami/letsencrypt/letsencrypt-auto certonly -w /home/bitnami/apps/wordpress/htdocs -d each1teach1.us -d www.each1teach1.us

image

After this then the one below comes up. Nothing about acme challenge so that my site will be found with the string that verifies it.
it doesn’t give me back the option except 1 keep existing certificate and 2 renew and replace certificate.

2 Likes

Since you are using LightSail with Bitnami image, please please please use your Bitnami image provided script to request and install a certificate.

Bitnami AWS cert-tool link: https://docs.bitnami.com/aws/faq/administration/generate-configure-certificate-letsencrypt/

I mean, it’s even pinned here: Using Bitnami? Please see Bitnami's documentation!

3 Likes

image

I tried bitnami ssl setup however my last error is below:

I have not idea how to fix this error…>>error:
httpd.bin: Syntax error on line 562 of /opt/bitnami/apache2/conf/httpd.conf:
Syntax error on line 72 of /opt/bitnami/apache2/conf/bitnami/bitnami.conf: Could
not open configuration file
/opt/bitnami/apache2/conf/bitnami/bitnami-apps-v:sse:ehosts.conf: No such file
or directory

I tracked and fixed everything but I am stuck on the last line. ehosts.conf does not exist.

1 Like

Guys what should I do I tried using lego to manually get a CA all to no avail.

Could not obtain certificates:
error: one or more domains had a problem:
[each1teach1.us] [each1teach1.us] acme: error presenting token: could not start HTTPS server for challenge: listen tcp :443: bind: address already in use
[www.each1teach1.us] [www.each1teach1.us] acme: error presenting token: could not start HTTPS server for challenge: listen tcp :443: bind: address already in us

Does anyone know this or have anyone seen this before this error is my nemesis.

This is the main issue it keeping popping all every time.
/opt/bitnami/apache2/conf/bitnami/bitnami-apps-v:sse:e
image

1 Like

Hi @lokdonJoe,

Are you definitely running

sudo /opt/bitnami/ctlscript.sh stop

before you run lego? (As per the instructions on https://docs.bitnami.com/aws/how-to/generate-install-lets-encrypt-ssl/#alternative-approach).

Could you please run that stop command and then also:

sudo ss -tlpn | grep -E ":(80|443)"

and tell me what output it creates, if any?

2 Likes

With this particular problem, I think you may have accidentally inserted some text in /opt/bitnami/apache2/conf/bitnami/bitnami.conf on line 72, while trying to quit vi.

That text which says:

bitnami-apps-v:sse:ehosts.conf

is meant to say:

bitnami-apps-vhosts.conf

If you fix that mistake, it should be back to normal.

3 Likes

_az thanks a lot your idea is the fix. Everything work like is it supposed to … This ticket can be closed now.

Thanks for your guys kindness…

3 Likes
2 Likes

You can close the ticket by marking a post as the solution.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.