Afther Encrypt SSL,Can't access my domain, aws, lightsail, wordpress

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:linqtechsolution.com.au

I ran this command:

It produced this output:

My web server is (include version):bitnami
The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:aws lightsail

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
After install Let’s Encrypt SSL,Can’t access my domain, aws, lightsail, wordpress
~~h~t~tp://linqtechsolution.com.au/ 3.24.84.198
-2

connect failure - perhaps firewall
V ht~t~ps://linqtechsolution.com.au/ 3.24.84.198
-2

The support bundle was uploaded successfully to the Bitnami servers. Please copy the following code:

763e5cff-43c5-9d14-c3c0-f649ed4290f2
when I did restar:
bitnami@ip-172-26-4-175:~ sudo /opt/bitnami/ctlscript.sh restart AH00526: Syntax error on line 46 of /opt/bitnami/apache2/conf/bitnami/bitnami.conf: SSLCertificateFile: file '/opt/bitnami/apache2/\xe2\x80\x9c/etc/letsencrypt/live/linqtechs olution.com.au/cert.pem\xe2\x80\x9d' does not exist or is empty apache config test fails, aborting /opt/bitnami/php/scripts/ctl.sh : php-fpm stopped /opt/bitnami/mysql/scripts/ctl.sh : mysql stopped /opt/bitnami/mysql/scripts/ctl.sh : mysql started at port 3306 /opt/bitnami/php/scripts/ctl.sh : php-fpm started AH00526: Syntax error on line 46 of /opt/bitnami/apache2/conf/bitnami/bitnami.conf: SSLCertificateFile: file '/opt/bitnami/apache2/\xe2\x80\x9c/etc/letsencrypt/live/linqtechs olution.com.au/cert.pem\xe2\x80\x9d' does not exist or is empty apache config test fails, aborting //// when i try to generate ssl again: bitnami@ip-172-26-4-175:~ sudo ./certbot-auto certonly --webroot -w /opt/bitnami/apps/wor
dpress/htdocs/ -d mydomain
./certbot-auto has insecure permissions!
To learn how to fix them, visit https://community.letsencrypt.org/t/certbot-auto-deploymen
t-best-practices/91979/
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for linqtechsolution.com.au
Using the webroot path /opt/bitnami/apps/wordpress/htdocs for all unmatched domains.
Waiting for verification…
Challenge failed for domain mydomain
http-01 challenge for mydomain
Cleaning up challenges
Some challenges have failed.

IMPORTANT NOTES:

  • The following errors were reported by the server:

Domain: mydomain
Type: connection
Detail: Fetching
mydomain/.well-known/acme-challenge/6c5vz9JVGsWq_E6cx5nm1Jq_Xyyxq
OrK-24LmbGeIWU:
Connection refused
Please help me to fix this problem, thanks.

1 Like

Hi @silverwind0905

you have to fix that buggy configuration.

Looks like you have deleted a file. But these

\xe2\x80\x9c

are special characters - in a folder name?

Or remove your https vHosts complete (first make a backup), so you have only a working port 80 vHost and you can create a new certificate.

But you need a running webserver to use http validation + webroot.

PS: Checked your domain - https://check-your-website.server-daten.de/?q=linqtechsolution.com.au - there are some older checks.

looks like you have created the wrong certificate:

Issuer not before not after Domain names LE-Duplicate next LE
Let’s Encrypt Authority X3 2020-01-19 2020-04-18 linqtechsolution.com.au - 1 entries duplicate nr. 1
Let’s Encrypt Authority X3 2019-11-25 2020-02-23 linqtechsolution.com.au, www.linqtechsolution.com.au - 2 entries
Let’s Encrypt Authority X3 2019-11-25 2020-02-23 linqtechsolution.com.au, www.linqtechsolution.com.au - 2 entries

You should create one certificate with both domain names - non-www and www.

1 Like

Hi JuergenAuer,
Thank you.
I alreay installed the encrypt successful.but I still can’t visit my web site.
Can you help whit this?
return some message at browser:
2www.linqtechsolution.com.au/:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)
///
Request URL: https://www.linqtechsolution.com.au/
Request Method: GET
Status Code: 500 Internal Server Error
Remote Address: 3.24.84.198:443
Referrer Policy: no-referrer-when-downgrade
Cache-Control: s-maxage=10
Connection: close
Content-Type: text/html; charset=UTF-8
Date: Sun, 02 Feb 2020 13:44:53 GMT
Server: Apache
Transfer-Encoding: chunked
X-Frame-Options: SAMEORIGIN
X-Powered-By: PHP/7.3.7
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng, / ;q=0.8,application/signed-exchange;v=b3;q=0.9
Accept-Encoding: gzip, deflate, br
Accept-Language: en,zh-CN;q=0.9,zh;q=0.8
Cache-Control: max-age=0
Connection: keep-alive
Host: www.linqtechsolution.com.au
Sec-Fetch-Mode: navigate
Sec-Fetch-Site: none
Sec-Fetch-User: ?1
Upgrade-Insecure-Requests: 1
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.117 Safari/537.36