Letsencryptauto - Certificate Not Issued Due to IPV6 Domain

Please fill out the fields below so we can help you better.

My domain is: www.example.com

I ran this command: ./letsencrypt-auto --webroot -w /bookmarkstroubleshootingdir/ renew --dry-run

It produced this output:
Domain: example.com
Type: unauthorized
Detail: Invalid response from


404 Not Found

Not Found


To fix these errors, please make sure that your domain name was
entered correctly and the DNS A record(s) for that domain
contain(s) the right IP address.

My web server is (include version): Server version: Apache/2.4.18 (Ubuntu) Server built: 2017-05-05T16:32:00

The operating system my web server runs on is (include version): Ubuntu 16.04.2 LTS

My hosting provider, if applicable, is: own server

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

Cert must be renewed. This must be the 3rd time I am doing this now. Always succeeded except this time.

I can see that the file http://www.example.com/.well-known/acme-challenge/KMaEd3aXV95Ozpe3s_GvE_M5Zl6EBxKXwdJcb9DUh2s is being created and later on being deleted by the script.

I created my own file to test. This file has the same owner and rights like the one being created by the script. .well-known/acme-challenge/test. I can see this file in my browser. I can see it when i use my phone with its own internet provider.

The script still getting the 404 error.

Further more I set up a new server and changed the router. Same error.

Checked the logs of apache and then I don’t see any action when I run the script. So I think the servers of Lets encrypt is blocked in some way.

What to do?

Hello @thebird,

Your site has 2 ips configured, one for ipv4 and one for ipv6 but the web server is not configured the same way for both.

This is the first time you see this issue because since a couple of weeks ago, Let’s Encrypt will prefer ipv6 if you have configured both ipv4 and ipv6 for your domain.


thanx, I’ll try that

1 Like


Thanx! This is great. I disabled the ipv6 on my domainname because my server doen’t have a ipv6 address.
After that and waiting a couple of hours the renewing worked!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.