LetsEncrypt not working with www

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: winclassy.com

I ran this command: certbot certonly --manual --preferred-challenges dns --server https://acme-v02.api.letsencrypt.org/directory --manual-public-ip-logging-ok -d ‘*.winclassy.com’ -d winclassy.com

It produced this output: congratulations, your certificate

My web server is (include version): apache2

The operating system my web server runs on is (include version): Ubuntu-18.04

My hosting provider, if applicable, is: bacloud.com

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
After setup, it gave a congratulatory message. Then, I tried using www.winclassy.com, the browser throws a certificate error. It works perfectly without www like this winclassy.com

1 Like

Hi @ken4ward

checking your domain there is no critical error visible - https://check-your-website.server-daten.de/?q=winclassy.com

Domainname Http-Status redirect Sec. G
http://winclassy.com/ 301 https://winclassy.com/ Html is minified: 100,00 % 0.060 A
http://www.winclassy.com/ 301 https://www.winclassy.com/ Html is minified: 100,00 % 0.063 A
https://www.winclassy.com/ 301 https://winclassy.com/ Html is minified: 100,00 % 3.404 B
https://winclassy.com/ GZip used - 19342 / 132040 - 85,35 % Inline-JavaScript (∑/total): 24/15951 Inline-CSS (∑/total): 2/3768 200 Html is minified: 147,38 % 4.466 I

Both connections (non-www and www) use the same new certificate

expires in 90 days	*.winclassy.com, winclassy.com - 2 entries

Looks like a caching problem.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.