Lets Encrypt issues

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: https://tenantcheckni.co.uk

I ran this command: I set lets encrypt up from plesk dashboard

It produced this output: no matter what I do the certificate isnt accepting the www. version of the website

My web server is (include version): its a Windows based VPN

The operating system my web server runs on is (include version): Windows

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): im using Plesk

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): No idea

Okay no idea about most of those answers but I'm at a total and utter loss. I have a Lets Encrypt certificate set up for a domain and now usually clients are happy that there is no www. as this is the current trend but this one client has everything printed etc with www. and the site is just not working if you type in the domain with www. it only works without, I have clicked to add the extra security to include www from what I read but nothing is happening.....I'm really stuck and no where else to go as I cannot find or actually call anyone/

Define "client".

Define "add the extra security".


also note:

Name:    tenantcheckni.co.uk

Name:    www.tenantcheckni.co.uk
*** can't find www.tenantcheckni.co.uk: Non-existent domain

Hi cheers for getting back to me, and the client is the person we did the website for, the website tenantcheckni

and while in Plesk dashbaord and from the Domains list, I selected SSL?TLS Certificate, and on the left hand side there is a box with settings in called Keep websites secured I clicked the the setting ison and also enabled Include the www subdomain, secured webmail secure mail and secure domain aliases and seems to be currently stuck on the message 'The domain is not secured with a valid certificate. A valid certificate will be later automatically issued and installed and that has been since sat.

What @rg305 was saying is that you do not have a DNS entry for your www domain name. You must create one before anyone could use that name to get to your site. And, also is needed to get a cert for that name.

In other words, this fails:


Hi okay sorry my misunderstanding, so just tried to then add it but then i get this

Registered domain name
This domain name already exists.

so am i best totally removing the whole thing and readding it to our systems to try and get the www included

I don't know what system is saying "name already exists". But, the public DNS system does not know what that name is. Use this tool and try both domain names to see:



Okay i have completely removed the CNAME record that was there and readded it so now another waiting game

I did not see any DNS entries for your www domain earlier. And still none now. Not a CNAME or A record.


i have them there

Hmm. Let's Debug test site cannot find your www domain. I can't explain but I am not as experienced with DNS problems as others here. I do not use that same config panel but the NS records seem wrong. Are they even needed? Or, shouldn't they point to the google domains name server?


Those records don't match what is seen on the Internet.
It is likely that the domain has been moved to another registrar or DNS Service Provider (DSP) and that panel no longer controls the actual domain.

Compare the TXT records shown to those found on the Internet:
v=spf1 +a +mx +a:vmE27BA0E.local -all
"v=spf1 include:zoho.eu ~all"

Compare the NS records shown to those found on the Internet:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.