LetsEncrypt Cert with EC2 Bitnami


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:www.baim.tv

I ran this command:./certbot-auto certainly --webroot -w /home/bitnami/htdocs/ -d baim.tv

It produced this output:files authorization procedure. bait.tv (http-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://baim.tv/.well-known/acme-challenge/3qIw13L53KSd-f4K71NaXF4M97MKeYUsUdb-nWTHPk:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:godaddy.com

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#2

certainly should be certonly ?


#3

Hello,

I’m sorry, but I did spell it correctly in the session but not here. So the error is still valid and script broke when running step #3 in the cert process.

Here is thee screen shot of the error.

Thanks,


#4

OK, just had to be sure.
Please place a TEST.TXT file in the acme-challenge folder to ensure it can be accessed from the Internet.


#5

Is this the true webroot of your site?

mkdir -p /home/bitnami/htdocs/.well-known/acme-challenge
touch /home/bitnami/htdocs/.well-known/acme-challenge/test.txt

http://baim.tv/.well-known/acme-challenge/test.txt


#6

Sorry, but I am not sure how to do this or why?


#7

No, I do not think so, sorry I was following the script. So do I need to replace this and with what? Sorry, this is new for me.


#8

What’s the output of this:

sudo grep -iR DocumentRoot /opt/bitnami/apache2/conf /home/bitnami/conf

#9

Here is the screen shot.

Thank you!


#10

From that I would guess that the webroot is this one:

sudo ./certbot-auto certonly --webroot -w /opt/bitnami/apache2/htdocs/ -d baim.tv

#11

Hi _az,

I ran it again and still get the same error. :frowning:


#12

¯\(ツ)/¯ I’m not sure. It could be your .htaccess file interfering, or it might be that the document root is still wrong.

Could you please try the document root test as suggested earlier in the thread?

sudo touch /opt/bitnami/apache2/htdocs/test.txt

Once that file is created, http://baim.tv/test.txt should be accessible.

and can you also show the contents of your .htaccess file in that directory?


#13

Ok, I ran the file and the link takes me to the website as you can see. What do I do next?


#14

It shows that we still have no idea how to upload files to your site and make it accessible from a browser.

What directory do you upload files to when you want to upload files to your site?


#15

Well, I am not really sure, but here is the S3 Bucket I upload the videos to:

baingram-media/root


#16

Maybe you’re sshed into the wrong place?

curl ifconfig.co

#17

Hello Patches!

I am not sure what this is as we do not get to move files on the server as far as I know.

Thanks!


#18

If you cannot copy files on the server you probably can’t install an SSL certificate onto it either. :frowning:


#19

I haven’t tried, but I ran the file you suggested and it returned the ip address 34.231.6.249


#20

So this is the right server. It’s weird that the DocumentRoot @_az found in your Apache configuration isn’t working.

Let’s try and find your WordPress installation by looking for the xmlrpc.php file it ships:

sudo find / -type f -name xmlrpc.php