Lets Encrypt wrong certificate date

I have some issue with lets encrypt certificate on one of my subdomains - mail.programyzadarmo.net.pl. It worked but for some reason letencrypt auto renew has stopped working so yesterday I generated a new auto certificate using the DirectAdmin panel. I have no issues for programyzadaro.net.pl domain and blog subdomain but mail.programyzadarmo.net.pl shows wrong date - https ssl certicate will be served with a valid time of: Sat, 17 Aug 2044 .

My domain is: programyzadarmo.net.pl

The operating system my web server runs on is - Centos 7.9

I can login to a root shell on my machine - Yes
I'm using a control panel to manage my site - Direct Admin

Thank You :slight_smile:

Hello @olobambolo,

I know nothing about DirectAdmin so I won't be able to help here but yesterday you renewed the certificate for your domain mail.programyzadarmo.net.pl and it is the cert shown when reaching your site here https://mail.programyzadarmo.net.pl but you are serving a self-signed certificate when you try to reach your server using smtp and imap ports.

This is certificate served:

Issuer: C = GB, ST = Someprovince, L = Sometown, O = none, OU = none, CN = localhost, emailAddress = webaster@localhost
            Not Before: May 13 00:13:50 2016 GMT
            Not After : Sep 28 00:13:50 2043 GMT

So you should try to know why your DirectAdmin panel is using this certificate for smtp and imap instead of your renewed and valid certificate.

Good luck,


Problem solved, I re-added the subdomain in DirectAdmin :slight_smile:
Thank You :slight_smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.