Jelastic let's ecrypt renew ERR_CERT_DATE_INVALID

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: aironjobs.com

I ran this command: let's encrypt ssl certificate renew

It produced this output: ERR_CERT_DATE_INVALID

My web server is (include version): [versNGINX Ruby 1.16.]

The operating system my web server runs on is (include version): UBUNTU 18.04

My hosting provider, if applicable, is: jelastic

I can login to a root shell on my machine (yes or no, or I don't know): no, I can't

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Aruba cloud dashboard -

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): I'm not using certbot

Hallo,
I tried to renew the SSL but something goes wrong: in the control panel the expiration date is 01 08 2021 (2021 08 01) but the browser sees the old date 24 04 2021 ( 2021 04 24).

I tried this in different machines so isn't a machine date problem.

Could someone give me some information about possible solutions?

Many thanks to everyone

2 Likes

Hi @gmatt

your site is offline. No http, no https, no non-www, no www.

So it's impossible to check your configuration.

3 Likes

Thank you Juergren,
I'm sorry...

Yet online...

3 Likes

Any help would be very appreciate...
Many thanks

3 Likes

The problem is simple.

Your client

is unknown.

Looks like you use a command from your provider - and that command doesn't work.

--> Ask your provider.

Your server

Server: nginx + Phusion Passenger 6.0.2

has a redirect http -> https. I have no idea if the client you use can work with such a redirect. There is no specific error message.

3 Likes

Hello, gmatt!

To resolve the issue quickly, we'd suggest contacting the Jelastic support team directly at support@jelastic.com

3 Likes

Hi @JelasticTeam

is this

a Jelastic-tool or something from the hosters control panel?

2 Likes

thank you Juergen for your time,
yes it's a tool in the Dashboard:
lets encrypt tool 06 05 21

4 Likes

Hello, @JuergenAueruergenAuer

This is the Jelastic add-on(tool), that implements Let's Encrypt functionality as a unique out-of-box integration with the most popular load balancer and application server stacks. In such a way, it gives a possibility to freely secure the majority of existing applications that are run in Jelastic.
During the installation, the add-on downloads and configures Let's Encrypt client (so-called certificate management agent (CMA)), requests certificates from Let's Encrypt Certificate Authority (CA), applies issued certificates to running software stack according to its SSL integration specifics and adds a special cron job to initiate certificates update when the expiration date is close.
You can read more about this here - https://jelastic.com/blog/free-ssl-certificates-with-lets-encrypt/

4 Likes

Hello,

thank you for your reply. I'll do so.

3 Likes

Yep, then it's a problem of that Dashboard.

Thanks, good to know.

2 Likes