Can't renew because: autorenewal in -31 days

I have the following situation: most probable after an update of directadmin the letsencrypt settings in directadmin were gone.

(supposed) Renewal date: Jan 16 21:13:06 2021 GMT
After enabling renewal in directadmin.conf: Let's Encrypt in use. Auto-renewal in -31 Days.

Now I can't renew the expired certificates.

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain

I ran this command: certbot --apache

It produced this output: le_http_01_challenge_pre.conf could not be found to be deleted. Certbot probably shut down unexpected

My web server is (include version):apache

The operating system my web server runs on is (include version):CentOS

My hosting provider, if applicable, is: transip

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):1.11.0

1 Like

Welcome to the Let's Encrypt Community :slightly_smiling_face:

Sorry you're facing this strangeness. It looks like your certificate should have autorenewed in December. Let's get to the bottom of this.

Please show the output of the following commands:

sudo certbot certificates

sudo ls -lR /etc/letsencrypt/archive

sudo ls -lR /etc/letsencrypt/live

Certificate History
1 Like

Can't forget the sudo! :grin:

1 Like

sudo certbot certificates

Saving debug log to /var/log/letsencrypt/letsencrypt.log

No certificates found.

sudo ls -lR /etc/letsencrypt/archive

ls: cannot access /etc/letsencrypt/archive: No such file or directory

sudo ls -lR /etc/letsencrypt/live

ls: cannot access /etc/letsencrypt/live: No such file or directory

Additional info, the letsencrypt folder contains: accounts csr keys options-ssl-apache.conf renewal renewal-hooks

More info: there are 2 websites on the vps, active and correctly working with lets encrypt. One of them wil autoupdate within 2 days or something.

Thanks in advance

1 Like

You're using the latest version of certbot, have no certificates, and yet have two working websites with Let's Encrypt certificates. How!? Where are they?

I just noticed that you said you are using a control panel. Are you using that or certbot to acquire your certificates?

I originally used DirectAdmin to acquire the certificates.
Did an update to DA and had no problems, but after finding out there was no renewal I checked the DA conf and found there was no reference to lets encrypt so I added it.

That lead to show me -31 days for renewal message in DA. But there seems no way to renew using DA.

Afterwards I tried using certbot. But I guess I must have messed up somewhere along the line using the command line.

A working site on the vps:

1 Like

Ok, the problem is solved.

After you asked about DA I realized the problem should be within DA.

So I

  • adjusted the DA conf, rebuild everything. (including: ./build letsencrypt)
  • requested new certificates (using: ./ request_single)
  • redid the settings within DA
    After that all was fine.

Thanks for your support and setting me on the right path!

Now is there a way to set this to Solved?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.