Let's Encrypt validation status 400

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: doge.edu-nv.ru

I ran this command: Enable SSL via vestacp with Let’s Encrypt

It produced this output: Let’s Encrypt validation status 400

My web server is (include version): Server version: Apache/2.4.18 (Ubuntu)
Server built: 2019-10-08T13:31:25

The operating system my web server runs on is (include version): Ubuntu 16.04.6 LTS

My hosting provider, if applicable, is: Self hosted server

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): vestacp

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Please see: Kindly help me with installing an ssl certificate on my new website bsgcars.com.ng

Vesta forum has a long thread on this error: https://forum.vestacp.com/viewtopic.php?f=11&t=18597

The latest release is from April 2019: https://forum.vestacp.com/viewtopic.php?f=25&t=18599
[not sure what version you have]

That said, it seems vestacp sits atop nginx.
If you are unable to find an easy checkbox fix to this problem and you don’t mind rolling up your sleeves and going in under the hood, I may have some ideas on how to… “work around” this problem in nginx.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.