Lets Encrypt Request Fail Too many certificates


#1

Hi,

I am getting following error can you people guide me how to resolve it.

There were too many requests of a given type :: Error creating new cert :: Too many certificates already issued for exact set of domains: knowbase.sotful.com
Please see the logfiles in /var/log/letsencrypt for more details.


#2

The short answer is that you have obtained 5 certificates for your domain (knowbase.sotful.com) in the past 24 hours, and hence run into the rate limit.

To obtain more certificates you need to wait.

What command are you running ? and what is wrong with the certificates you already have ?


#3

Hi,

We tried to get the certificate first and getting the error :request failed
: Expected certificate file /etc/letsencrypt/keys/cert.pem was not found
therefore i tried many times can u please give the solution for the above
error.

Regards Talha


#4

Can you tell me exactly what commands you were runnning please ?

can you also provide the details from “Please see the logfiles in /var/log/letsencrypt for more details.” It may be easier to paste the log in pastebin.com


#5

yes i did from virtualmin , now i tried with certbot command ./certbot-auto config_changes -d aleresoftware.com -d www.aleresoftware.com and getting the successfull message IMPORTANT NOTES:

  • Congratulations! Your certificate and chain have been saved at
    /etc/letsencrypt/live/aleresoftware.com-0001/fullchain.pem. Your
    cert will expire on 2017-01-11. To obtain a new or tweaked version
    of this certificate in the future, simply run certbot-auto again
    with the “certonly” option. To non-interactively renew all of
    your certificates, run “certbot-auto renew”

but when i open the web it show me previous certificate .


#6

So, you have a certificate at /etc/letsencrypt/live/aleresoftware.com-0001/fullchain.pem

Since you did it from certbot, rather than viirtualmin, you will need to manually install the certificate into your virtualmin - https://www.virtualmin.com/documentation/tutorial/how-to-add-an-ssl-certificate


#7

but when i did from virtual min there was no need for dedicated ip. it gets the certificated and all the stuff.

Now, it is there any way to install with shared ip ?


#8

Hi,

log file details:

2016-10-13 07:25:05,375:DEBUG:certbot.main:Root logging level set at 20
2016-10-13 07:25:05,375:INFO:certbot.main:Saving debug log to /var/log/letsencrypt/letsencrypt.log
2016-10-13 07:25:05,384:DEBUG:certbot.main:certbot version: 0.9.2
2016-10-13 07:25:05,384:DEBUG:certbot.main:Arguments: [’-d’, ‘aleresoftware.com’, ‘-d’, ‘www.aleresoftware. com’]
2016-10-13 07:25:05,385:DEBUG:certbot.main:Discovered plugins: PluginsRegistry(PluginEntryPoint#standalone, PluginEntryPoint#manual,PluginEntryPoint#nginx,PluginEntryPoint#webroot,PluginEntryPoint#apache,PluginEntry Point#null)
2016-10-13 07:25:05,411:INFO:certbot.reverter:Certbot has not saved backups of your configuration


#9

Yes, the certificates work fine with SNI on shared IP.

You started with an error of “Too many certificates” for knowbase.sotful.com
You provided the log file for aleresoftware.com - which doesn’t have this issue, and hence the log file doesn’t show the issue. Can I ask that we deal with one topic at a time please ? or at least make it clear what topic / question you are asking.


#10

Hi,

Actually the thing is i tried for knowbase.sotful.com it was blocked then. Now, therefore for new domain aleresoftware.com i requested ssl from virtual min i get the error Expected certificate file /etc/letsencrypt/keys/cert.pem was not found so i am so confused what to can you please help for aleresoftware.com how to fixed it .

Regards Talha


#11

You would need to check with the virtualmin implementation of LE for that, I’m not familiar with it.

The path looks wrong though, it shouldn’t be /etc/letsencrypt/keys/cert.pem by default (which may be why it’s failing). I don’t know if that is something that’s set in the virtualmin config or not.


#12

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.