Let's Encrypt Not Working


#1

Please fill out the fields below so we can help you better.

My domain is: healthyaginghabits.com

I ran this command: I have no idea what this is. I set up Let’s Encrypt (LE) via my hosting in CPanel. It’s working fine for two other sites. I have no clue why it’s not working for this site. I’ve tried different browsers, clearing cookies, deleting and reinstalling. Totally new to this.

It produced this output: not secure

My operating system is (include version): Mac OS 10.12.4

My web server is (include version): Not sure what this is. Under “Server Information” I see Server Name: “s3”

My hosting provider, if applicable, is: FastComet

I can login to a root shell on my machine (yes or no, or I don’t know): I don’t know

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
Yes, I’m using cPanel v64.0.21 as mentioned above

Please make your helpful replies simple and easy if possible. Please don’t “assume” anything. Thank you for your understanding. Standing by.


#2

Hi @fillip,

I think the best course would be for you to ask your hosting provider’s support. The questions that you found confusing or unfamiliar mostly assume that people are administering their own servers, not using shared hosting with a control panel.

In a small number of situations, we can help people who are using shared hosting with a control panel like cPanel, but generally we don’t have enough information, nor enough ability to fix the problems, so your hosting provider’s support is in a much better position to help you.

However, I took a look at the site and it looks to me like the certificate is a valid, correct Let’s Encrypt certificate, correctly installed, and people can access your site over a secure connection. So, if you’re just wondering about the site security warning or the lack of a padlock when viewing your site in web browsers, this is because of a mixed content error—including insecure HTTP resources, such as images or scripts, within a secure HTTPS page. You can diagnose mixed content problems with a tool like

https://www.whynopadlock.com/


#3

Hi @schoen
Thank you for the reply. That’s good to know that the site’s secure. I ran the “WhyNoPadlock”.

Got this:


Insecure <form> call. 

Found on line # 190 in file: healthyaginghabits.com/index.html
Insecure call.
Found on line # 419 in file: healthyaginghabits.com/index.html

(Note: Chrome will show a security error for any secure page with an insecure call on the page)


Which I have no clue how to fix. Anyhow, thank you so much. I’ll go to Chrome forums and see what they can offer.


#4

Hi @fillip,

If you go to your site and then use your browser’s View Source feature, you can see the items that whynopadlock is referring to. But if you don’t have the ability to edit the HTML source of your site directly, or the habit of doing so, you’ll probably need to look into WordPress settings and plugins to make sure that they stop referring to http:// resources and locations instead of https:// versions.


#5

Hi @schoen
I got it! Thank you so much. The key was to take this problem to my hosting-what you recommended. They said all I need to do is download the “Really Simple SSL” plugin. A-batta-bing-a-batta-boom, I’m HTTPS all the way.

Thank you for helping me go in that direction.Sometimes, it’s difficult to know who to contact since things are so connected.

Anyhow, problem solved. It’s custom where I live to show thanks and appreciation with
a bow… m(_ _)m


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.