Let's Encrypt in FileZilla

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version): Win10 pro

My hosting provider, if applicable, is: dynDNS

I can login to a root shell on my machine (yes or no, or I don't know): yes?

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Hello, I am looking for some help setting up Lets Encrypt in FileZilla.

I get to the point in FileZilla under FTP and FTP over TLS where I can click on generate. It asks for a hostname. I have put my DynDNS hostname and it keep kicking back this error:

image

I have checked that the FTP ports are open and working at this website https://ftptest.net/

It shows every thing is open and working.

Welcome @kcirevam

You are using an HTTP Challenge to get a cert. The Let's Encrypt Server(s) need to reach your domain using HTTP on port 80 to validate your domain.

4 Likes

I appreciate the response.

I am also not sure what it means. Sorry I am very much just a hobbyist.

Could you break it down a bit further.

Thank you.

1 Like

This, but then for port 80 instead of FTP port 21.

Also note that getting help on this Community without providing the MANDATORY domain name might be difficult.

1 Like

Once again thank you.

I have opened port 79 through 81 and it kicks back the same error.

2 Likes

Then clearly something is still not configured correctly on your system.

Or, perhaps your ISP does not allow inbound connections on port 80. Is this a residential service? Some don't allow port 80.

Are you following instructions like below? If so, what did you enter for the challenge answers? It is about at 1m10s at the video link below

How to Install TLS Certificate - FileZilla Pro.

If you want more specific advice you need to provide your domain name.

Most of us here are unpaid volunteers offering our time and expertise for free to you. Having to guess and ask extra questions just wastes all of our time. And, without the detail answers we just can't give specific advice.

3 Likes

Hello,

Sorry I am not trying o be difficult.

I have tried both internal and external challenges.

For the internal I tried changing the port to something other than 80 in case that was the problem.

For the external I used the path c:\certificate

I got the error for all these attempts.

The error mentions that it could be a firewall issue. I double checked, my firewall is off.

Hi @kcirevam,

And what about your ISP's possible firewalls?
And to assist with debugging there is a great place to start is Let's Debug.

Or is there geo blocking, possibly by your country
Please read these:

Also testing and debugging are best done using the Staging Environment as the Rate Limits are much higher.

2 Likes

Then please:

3 Likes

Check that your ISP actually supports HTTP (tcp port 80) traffic on your connection, some don't. This is required to achieve http domain validation.

3 Likes

In the interest in passing on solutions, I changed my DMZ settings. I am using the bell giga hub and had the sever in the advanced DMZ. When I turned that setting off it seemed to work.

thank you for all the help. I know you are all volunteers and I really do appreciate the time you took to help me out.

3 Likes

All of the VOLUNTEERS here are trying to help you resolve YOUR issue.
Why do you not share YOUR DOMAIN NAME???
Is there really a domain involved?
"I don't mean to be a pain" but you need to provide us publicly available information so we can assist you in resolving YOUR issue and stop wasting time.
No offense intended

2 Likes