Failed to connect to Let's Encrypt. Please make sure domain name is valid

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: I tried creating a certificate through Synology DSM.

It produced this output: Failed to connect to Let's Encrypt. Please make sure domain name is valid.

My web server is (include version): Synology DSM 6.2.3-25426 Update 3

The operating system my web server runs on is (include version): Synology DSM 6.2.3-25426 Update 3

My hosting provider, if applicable, is: Not applicable

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Synology DSM 6.2.3-25426 Update 3

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Ports 80 and 443 were closed when renewal was needed. Now I can't create new certificates.
I searched the web and tried few solutions which didn't work. One of them was to delete all certificates and start new but now I can't create new cert as well.

Ports are open properly. I checked it with Also this worked before when I was creating a certificates in the first place.

If any additional info is needed, I'm happy to provide. Thank you for the help.

1 Like

Hi @zzrakic

that's not your domain, that domain isn't registered - see - Make your website better - DNS, redirects, mixed content, certificates

Host Type IP-Address is auth. ∑ Queries ∑ Timeout Name Error yes 1 0 Name Error yes 1 0

You need a registered, worldwide unique domain if you want to create a certificate with that domain name.


Hi JuergenAuer,

Thank you for the quick reply.

Apologies for the confusion. I mistyped it.

It is I will try to edit the post and correct it.

1 Like

The error is expected.

Your port 80 redirects to port 5001.

Checking your domain Letsencrypt follows redirects.

But only domain names and port 80 / 443 are allowed.

So your configuration is ACME-incompatible.

1 Like

Thank you for the reply. I managed to create new certificates and set them for my domain.

Unfortunately, I'm still getting error below.


Tell me if you need more information.

1 Like is valid. May be remove the redirect http -> port 5001 + https.

1 Like

I have removed reverse proxy for port 5000.
Still getting the same error. Also I get this error for my subdomain.

Does it actually say "Failed to connect to Let's Encrypt."? Because that implies your NAS can't reach out to the Let's Encrypt server all together.

While @JuergenAuer has a point that a redirect from HTTP port 80 to port 5000 would make any http-01 challenge fail (the port 80 -> 5000 redirect is still present by the way), it seems you're not even getting to the validation step anyway, as your NAS can't reach Let's Encrypt to begin with.

1 Like


is the same wrong redirect to port 5000.

Same error -> same not working result, that's expected.

1 Like

It appears that everything is working now.

Thank you both for the amazing support. You were very resourceful and helpful!

Have a great week.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.