[Let's Encrypt for cPanel] Failed to request service certificate


#1

Hello,

Sins a few day’s when generate a service certificate for whm the following error occure.

An error was encountered requesting certificate for host domain cloud1.usdc.econoweb.be,mail.reizengies.be,mail.hetfitnessnetwerk.be:

** The Let’s Encrypt HTTP challenge failed: acme error ‘urn:acme:error:unauthorized’: Invalid response from http://mail.reizengies.be/.well-known/acme-challenge/SbjNEhGEHjOnOgCKB0hZcevQeYg4c9ytsf5PvH3p3H8: " **
404 Not Found

Not Found


Th"

Anny idea what the problem can be?

The directory http://mail.reizengies.be/.well-known/acme-challenge is availeble but there is notting in it.

Please fill out the fields below so we can help you better.

My domain is:reizengies.be

I ran this command:

It produced this output:

My operating system is (include version): CLOUDLINUX 7.3

My web server is (include version): WHM 6.0

My hosting provider, if applicable, is: myself

I can login to a root shell on my machine (yes or no, or I don’t know): YES

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): WHM 6.0


#2

If you place a plain text file called “test” in the folder, can you reach it on a browser at http://mail.reizengies.be/.well-known/acme-challenge/test ?


#3

yes i can acces that

http://mail.reizengies.be/.well-known/acme-challenge/test.txt


#4

Sorry, just to test, can you do it without an extension please, and check it’s in plain text ( so just test not test.txt )

OK, thanks - that works OK.

Can you add the --debug command on your certbot run please, and then paste the output ( usually easier into pastebin.com as it’s informatted, and you can also easily delete it afterwards.


#5

yes that il also working


#6

OK, thanks

Can you add the --debug command on your certbot run please, and then paste the output ( usually easier into pastebin.com as it’s informatted, and you can also easily delete it afterwards.


#7

sorry, i am realy new in to this.
What is the certbot command


#8

Sorry, my fault, you are using the WHM LetsEncrypt plugin rather than the full “certbot” client.

I’m not sure there is a debug option on the WHM command - I assume this was set up using AutoSSL ? Can you just run it again in WHM, and paste the complete log please ? (in pastebin.com is fine )


#9

http://pastebin.com/zLRqkqiw


#10

Thanks,

As I’m going through this - I see there is tethe error “Disk quota exceeded at bin/autossl_check.pl” Can you check which disk space is over quota and then delete files ( or increase the quota ) to correct that please.


#11

That log file doesn’t contain any errors for mail.reizengies.be

There are other errors though, most are because the SSL cert wasn’t installed via AutoSSL originally. And there were the quota issues.

If you want to check it for mail.reizengies.be ( or a different domain) could you just run autossl for that specific domain ?

You can remove that original paste again - thanks.


#12

is it possible that that the auto SSL only is affecting the normal certificates? The normal certificates are working.

For the service certificates i used

-le-cp hostcert enable
-le-cp hostcert add mail.reizengies.be


#13

Ahh, OK - this is the paid plugin " https://letsencrypt-for-cpanel.com " is it ? not the official cpanel system for Let’s Encrypt ( AutoSSL https://documentation.cpanel.net/display/CKB/The+Let’s+Encrypt+Plugin )

I have never used the paid plugin, sorry. I’d suggest either contacting their support folk, or changing to the official cpanel plugin.


#14

indeed it is, , i am going to remove the paid one and use the official one.

manny thants for your help


#15

You’re welcome - sorry I was a bit low catching which plugin you were using.


#16

i have removed the paid plugin and installed the official on.

the certificate is generated for the following domains

mail.reizengies.be
reizengies.be
www.reizengies.be

Is this certificate automaticly used as a service certificate


#17

by default, yes ( you can change that in WHM settings, if you have left it as default though, yes).


#18

thanks again, it is working now


#19

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.