Let's Encrypt certificate expiration notice for domain - RHEL 6

Hello All,

I have got an email from Let’s Encrypt stating that the certificate will expire by 24th Sep 2017 for our domain.

I tried to renew the certificate by using Certbot and getbash, but they are not working.
Can anyone share the procedure or process to renew the certificate for our web site. Please find the bellow details,

mounted on : Apache web server
OS: RHEL 6.9

Tried the links

Got an error “-bash: ./getssl: No such file or directory” from bash while executing the command "./getssl -c "

Thanks and Regards,

You will get better assistance usually if you share exactly what happened rather than saying things like “they are not working” which could mean anything. For example pasting error message text, or screenshots. It can also help to know, among other things: Did previous renewals work, or is this your first renewal since you got the certificate originally?

1 Like

This is our first renewal, at first I followd the procedure available in the link https://github.com/srvrco/getssl

While trying to execute the command "./getssl -c ", Im getting the error “-bash: ./getssl: No such file or directory”

While trying the link “https://certbot.eff.org/#centosrhel6-apache”, Im getting error while executing the command "sudo ./path/to/certbot-auto --apache"
I have a doubt on which path we need to give here.

Hi @Kasirajan,

I think your problem could be a misunderstanding of what this documentation is referring to in terms of Unix paths.

./getssl means to run the getssl program from the current directory, so if you’re using getssl, you have to cd to whatever directory getssl is installed in before running that command. It won’t work if you’re in any other directory.

sudo ./path/to/certbot-auto does not mean to literally type the string ./path/to/certbot-auto. Rather, that is supposed to be replaced by the particular directory path where certbot-auto was downloaded on your system.

In both cases, the documentation assumed that you know what directory the program is located in (because you would have previously downloaded it yourself), and is asking you to specify the appropriate directory in order to run the program. This is common for Unix software that you download yourself, because you’ll have a choice of what directory to save it into, and that directory is probably not in the default PATH and therefore needs to be specified explicitly when running the software.

Also in both cases, renewal instructions are probably assuming that you previously used that same software to obtain your original certificate. So a relevant question is exactly how the original certificate was obtained (by running what command).

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.