Let's Encrypt certificate expiration email


#1

Hi
I get the certificate expiration email saying my domain will expire shortly, but when I run Letsencrypt in my docker container it tells me that it is not up for renewal yet. Whats happening?

My domain is:
vesselallocationservices.com

I ran this command:
certbot renew

It produced this output:

The following certs are not due for renewal yet:
/etc/letsencrypt/live/vesselallocationservices.com/fullchain.pem expires on 2018-09-06 (skipped)
No renewals were attempted.
No hooks were run.

My web server is (include version):

Operating System: Linux
Software: Apache/2.4.25 (Debian)
MySQL version: 5.5.5
PHP Version: 7.2.7

My hosting provider, if applicable, is:
N/A

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
N/A


#2

Hi,

It seems that you issued tons of certificates…

https://crt.sh/?q=vesselallocationservices.com

I think the email was coming by the certificate that was going to expire on the 30th…

Since I can’t connect to your webserver, I don’t know what certificate you are using, but it seems that you are not use the nearly expired one now…

Thank you


#3

Hi Stevenzhu,

Hups :-), as you can see I am a tad behind understanding how it works and yes, I have changed names and updated, reinstalled etc. etc. as my site is under development but from now on it needs to stay as it is. So sorry for my newbie questions,

  1. what douse it means that I have so many certificates, can they be deleted? I am using letsencrypt in a docker and thought it only saved one cert
  2. Do I have to do something about it or just wait until they have expired? and if what do I have to do?

Just started my production site so dont want it to go down,

R Kru-x


#4

Hi,

Yeah…if you use docker, it will not save any certificate you previously obtained. However, all certificates you obtained will be saved in a database (certificate transparency)

Well, if you are not using those certificates (the near expiring certificates), you don’t need to do anything …

Thank you


#5

Superstar, you are! Thanks a lot, but I am not sure why it issues that many certificate, guess it might be when I restart the container? As long as I don’t mess with the system I am happy.
J


#6

Probably. Be careful, you could hit a rate limit. Better if the container is configured to put the cert/key in some sort of persistent storage.


#7

What is the rate limit? The one certificate that I have, is in a persistent storage, seem like my docker container played up in may - june nothing more after that. Have a feeling it could have been me, duhhh


#8

#9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.