Let’s Encrypt Wordpress plugin: Registration key is already in use

My domain is: http://www.ardentshopping.com/

I ran this command: let’s encrypt wordpress plugin

It produced this output: Let’s Encrypt: Registration key is already in use

My web server is (include version): apache, cloud shared server.

My hosting provider, if applicable, is: bigrock.in

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): yes

Hi there, i have used this plugin on many other sites. On this site i am getting this issue that after installing the plugin on a fresh wordpress site. (Have not uploaded any extra theme yet, its a fresh install) There is no other plugin installed yet.

After activating, i vent to the settings and lets encrypt page, i filled the information and clicked on save and as there is a button called “Register Account” if i click that button i see this error —> Let’s Encrypt: Registration key is already in use

Please ask me any information if you need. Thank you guys.

i deleted the folder from the cpanel and then tried to click on the button name “Register Account” then i am getting this error —> No HTTP challenge available for domain www.ardentshopping.com. Original response: {“type”:“urn:acme:error:unauthorized”,“detail”:“No registration exists matching provided key”,“status”:403}

I reset the database and reinstalled the vordpress again.
i installed the plugin again and activated it.
tried again and hit the button register account and i see this error —> Unknown error

I tired changing the name and hit save and again i see this issue —> Let’s Encrypt: Registration key is already in use

Greetings. I’m running into the exact same issue : first I get an “unknown error”, then “Let’s Encrypt: Registration key is already in use” I uninstalled and try installing again with same results. I’m running wordpress 4.9.1. Please advise.

Please someone help us…

Have you found solution for this ?

Not yet, i request someone to help us.
Here is my own website --> www.khalsa-website-designers.net where i am running the ssl certificate from let’s encrypt properly but on my client’s site this plugin is giving me issues.

This is really unprofessional … all the guys are asking for the same issue … and no developer is ready to reply us …

This forum isn’t a support channel for that plugin. The most likely place you will have success asking for help is on the plugin’s support forum:

https://wordpress.org/support/topic/error-registration-key-is-already-in-use/ (where I see you have already posted. If the developer is ignoring you there, I am not sure you will have better luck here).

On that forum you will also notice that the developer is no longer maintaining the plugin, which would explain their silence.

There’s nothing we can do to fix it unless somebody volunteers to fork it (feel free).

1 Like

I’ve managed to create a workaround. The issue is something to to do with the account registration keys - on my host they are:

/var/www/letsencrypt/live/account/private.pem
/var/www/letsencrypt/live/account/public.pem

It may be possible to just delete these files (and other letsencrypt certs) and start from scratch - your risk!

My working method was to insert the [wp_encrypt_registration] record into the [wp_options] table for the problematic site from a working SSL site. You will need to change the URL information in your new copy to reflect the problematic site.

Hope this helps


UPDATE

…and, here’s an absolutely horrible hack that disables the registration validation:

In WP-Encrypt - CertificateManager.php

/**
		 * Retrieves information about a Let's Encrypt account.
		 *
		 * @since 1.0.0
		 * @access public
		 *
		 * @param string $location Endpoint URL for the account.
		 * @return array|WP_Error The response if successful, an error object otherwise.
		 */
		public function get_account( $location ) {
			$response = Client::get()->signed_request( $location, array(
				'resource' => 'reg',
			) );

			if ( is_wp_error( $response ) ) {
				return $response;
			}		
			
			
			* Horrible Hack to allow account registration to proceed
			*
			if ( isset( $response['status'] ) && 200 !== absint( $response['status'] ) ) {
				return $this->parse_wp_error( $response );
			}
			*
			*/
			
			$response['location'] = $location;

			return $response;
		}

I’m considering picking up the development on this once I’ve exchanged a few emails with the original dev

3 Likes

Glad to see you’ve come up with a solution, @robmason38!

Guys, i found one more solution. Actually the issue is related to the account activation. I contacted my hosting team and they said to me to fix this issue via SSH.

I told them that i do not know how to do the SSH. Then they asked me to find the developer who knows. I vent to Fiverr.com and found someone vho actually fixed this issue in 1 hour. I am going to mention his profile link so that you can also contact him and get this issue fixed --> https://www.fiverr.com/juraganet

Just contact this guy and tell him that you need this Lets Encrypt issue fixed via SSH. He will do it for $20.

Guys, this was the domain which was having issue with the letsencrypt registration --> https://www.ardentshopping.com/ and nov after this fiverr guy service my client’s domain is fine.

This guy from fiverr has a gig on this link —> https://www.fiverr.com/juraganet/do-linux-server-install-maintenance-or-migration?ref_ctx_id=3afb86f3-bfc8-447a-98c3-12eca3966359

Just get in touch with this guy, as he is really good at fixing this issue which we all are facing. If you need to ask any question then just go to fiverr and get in touch with this fiverr guy and he will help you.

Best of luck guys. I hope i helped. You can visit my website here --> www.khalsa-website-designers.net

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.