Kernel 6.1.54 - certbot not working

I am running Nextcloud on a pi4 currently with bookworm kernel 6.1.53 and this certbot data:

bookworm-[6.1.53-v8+]-root@nextcloudpi:~ #
Name Version Rev Tracking Publisher Notes
certbot 2.6.0 3026 latest/stable certbot-eff✓ classic
core 16-2.60.3 16096 latest/stable canonical✓ core
core20 20230801 2019 latest/stable canonical✓ base

apache2 -v
Server version: Apache/2.4.57 (Debian)
Server built: 2023-04-13T03:26:51

Making a certcheck and autorenew with certbot are working.

After upgrading to kernel 6.1.54 the
dry-run is no longer working and the renew also stops with
'can not write wellknown-acme challenge'

Reverting to kernel to 6.1.53 solved the problem for now
but I am afraid that further kernel-updates will bring back the problems.

The path would be /.well-known/acme-challenge/ but the error has removed the path separators and the ., not sure if that's normal or not. Could be a python bug. Certbot is unlikely to be making filesystem syscalls itself directly.


OK. Thank you.
I just updated "everything"and reinstalled 6.1.54. The error is no longer visible.
I noticed that while is was occuring certbot tried to renew the certificat and I also tried to make
a dry-run. Maybe it is the reason for this error, because port 80 is opened only for certification via pre-hook and closed via post-hook.
So for now 6.1.54 is currently working with the dry-run-option.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.