JWS verification error

Hi

I ran this command:

$dnsIdentifiers = @("example.com","www.example.com"); # Strings will automatically be converted to AcmeIdentifier
$order = New-ACMEOrder -State $acmeStateDir -Identifiers $dnsIdentifiers;

It produced this output:

Server returned Problem (Status: 400).
Type: urn:ietf:params:acme:error:malformed
JWS verification error

What is the reason for this error?
Maybe because of the example domain?

1 Like

Does it not “error:malformed” with only a single name?

1 Like

It’s the same when i use a single name

Are you using a real domain?

1 Like

No, it is not a real domain
i just want to check my code before i use a real domain

Then check your code against the staging system (not production).
And use a more realistic name (even if not an actual real one).

1 Like

I use LetsEncrypt-Staging

1 Like

Try using a more realistic name.
Say your real domain is:
server.domain.com
Then try:
notserver.domain.com
testserver.domain.com
serverxyz.domain.com
[none of which need to be resolvable - but could be]

1 Like

Thanks, got it
i will do that

2 Likes

I don’t know that that will fix the prblem.
[probably won’t]
But I have to rule it our first.

So, if it doesn’t, then I would suspect that there may be an issue with the “type” and the “value(s)” used by “$dnsIdentifiers” in your code [or localization issue].
For that, I would try a simple set and then print back the value(s) and compare.

1 Like

It is still not working
How do you mean to compare the values?

Well like in any programming language.

You can try setting the variable with a specific single value.
Show/Print it.
Then set it with a multiple entries value.
Show/Print that.

If the output doesn’t equal the set input, then the code has a problem.

I checked and it is equal…What can be the problem?

I don’t have enough information nor (possibly) knowledge of the program you are using to help you any further.

Maybe there is a support page for that client.