Acme: error: 400 :: POST :: https://acme-v02.api.letsencrypt.org/acme/new-order :: urn:ietf:params:acme:error:malformed :: JWS verification error, url: )

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: cluster3-ambassador.api-dev.prov.clinical6.com

I ran this command:

It produced this output:
Error (obtaining tlsSecret "cluster3-2dambassador.api-2ddev.prov.clinical6.com"."default" (hostnames=["cluster3-ambassador.api-dev.prov.clinical6.com"]): acme: error: 400 :: POST :: https://acme-v02.api.letsencrypt.org/acme/new-order :: urn:ietf:params:acme:error:malformed :: JWS verification error, url: )
My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):Due to this error, any of my microservices are not working. can anyone provide me support on this.

2 Likes

This error is typically indicative of an ACME client message formation problem. Based on what you've presented, I surmise that the url might be missing from the message.

2 Likes