Error when trying to verify domain


#1

I tried to issue a certificate and get the following response:

Error: Domain challenge failed. Please start back at Step 1. {“type”:“urn:acme:error:malformed”,“detail”:“Unable to read/verify body :: JWS verification error”,“status”:400}
I tried it several times, namelookup for the domain works, I can browse it manually.

Any Ideas what went wrong?


#2

If you’d ask me, I’d say your server responds to the ACME inquiry for the challenge with a HTTP 400 Bad Request (because of the 400 in the error…), but I can’t really think of a good reason why…
What do your webserver access logs say when you execute the Let’s Encrypt client? And run the client with the -vv switch for more debug info please.


#3

I’d also try creating .well-known/acme-challenge/somefile manually and see if you can then reach it in the broswer. you may have a redirect / .htaccess issue that’s stopping access.


#4

Try to do the verify process via SSH:

echo -n "insert-second-row of code-here" > insert-first-row-of-code-here

You possibly mixed up the file name with the content?