Issued a Cert Successfully but Still Insecure in Browsers


#1

Hi,

My domain is: bebegimmagnetleri.com

I ran this command:
sudo certbot certonly --apache -d bebegimmagnetleri.com -d www.bebegimmagnetleri.com

It produced this output:
“Congratulations! Your certificate and chain have been saved at:
/etc/letsencrypt/live/bebegimmagnetleri.com/fullchain.pem
Your key file has been saved at:
/etc/letsencrypt/live/bebegimmagnetleri.com/privkey.pem
Your cert will expire on 2018-12-23. To obtain a new or tweaked
version of this certificate in the future, simply run certbot
again. To non-interactively renew all of your certificates, run
“certbot renew””

My web server is (include version):
Apache version 2.4.6

The operating system my web server runs on is (include version):

CentOS Linux 7.5.1804

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
Webmin 1.890

I have issued a certificate successfully.

When I run the command below, it shows the certificate is valid till Dec 23.

openssl x509 -noout -dates -in /etc/letsencrypt/live/bebegimmagnetleri.com/cert.pem

notBefore=Sep 24 04:19:58 2018 GMT
notAfter=Dec 23 04:19:58 2018 GMT

But when open it from a browser, the site is insecure, validation data displays as 24/09/2018 instead of new one (Dec 23)

I have issued certificates for this domain several times before, and had no issue.

Thank you


#2

Hi @bdan

this looks only like a caching problem of your browser.

No mixed content warnings, your certificate is created today.

Same with Chrome - Ctrl - Shift - I, then Security:

So use another browser or clean your cache to test it again.


#3

It is okay now.

I have tried with multiple browsers and computers with and without clearing cache but all showed the not-secure message.

Only thing I did was a soft apache restart, not sure if that was the issue, it started to show as secure after a while.

I have renewed the certificates for different domains several times, just a ctrl+f5 was enough to see the new certificate.

Anyway, it is resolved now.

Thanks for your time


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.