1 out of 4 certificates doesn't seem to work

My domain is:
rapid-automation.net, sawgrasslakes.org, www.rapid-automation.net, www.sawgrasslakes.org

I ran this command: Chrome browser

It produced this output:
https://sawgrasslakes.org shows an 'unsafe site'.
While https://www.sawgrasslakes.org is fine.
So are the other two.

My web server is (include version): Apache 2.4

The operating system my web server runs on is (include version):
Ubuntu 20.04

My hosting provider, if applicable, is:
Self hosted

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Found the following certs:
Certificate Name: rapid-automation.net
Serial Number: 42e756062e33f62884a840c4bc486b40296
Key Type: RSA
Domains: rapid-automation.net sawgrasslakes.org www.rapid-automation.net www.sawgrasslakes.org
Expiry Date: 2021-07-14 04:23:33+00:00 (VALID: 89 days)
Certificate Path: /etc/letsencrypt/live/rapid-automation.net/fullchain.pem
Private Key Path: /etc/letsencrypt/live/rapid-automation.net/privkey.pem


1 Like

Looks good currently, maybe apache needed a restart? I see the sites aren't configured to auto redirect http to https but the https version of each site is working.

1 Like

Thanks for looking into it! Much appreciated.
And indeed it now seems to work for me too. I DO religiously restart apache after messing with .conf files, so I wonder if this cert stuff is maybe cached somewhere, with a cache timeout? (Although these four were all done at the same time).
Oh well, not important: it works now.

1 Like

Some more information!
It appears to be a Chrome browser issue! When I tried this 10 minutes ago in a new tab, to my surprise it indeed worked the way it should.
Then I noticed I still had a tab with the failed attempt, and I did a refresh, and again it said 'Site not secure" (but oddly, if I expanded that 'Not secure' message, it DID say 'certificate valid').
I then browsed to something else, from that tab, which worked, and then I typed in the failing https URL again and AGAIN it told me "Site is not secure". When I then removed that tab, and typed in the same URL in a new tab, it worked just fine.
So, it must be a Chrome issue, with not clearing things (cached?) on a per tab basis. Deleting those tabs fixed it.

1 Like

Thanks for reporting that. This could help others having the same problem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.