Issue installing LetsEncrypt certificate on Siteground


#1

Hello,

I have a multistore Magento 2 and 1 website is running LetsEncrypt certificate. But the other has issues. Siteground says:
I checked the case in detail and it seems there is no actual SSL installed on the server for uitverkoopgigant.nl. The SSL checker that you use utilize cache and this is why you are able to see the previous results.

At the moment however there is an ongoing issue with Let’s Encrypt that prevents some SSL’s to be issued as intended and the certificate for uitverkoopgigant.nl is affected.

We are investigating the issue in detail however we can not provide any ETA about when it will be fully resolved.

Can someone help me?


#2

#3

Thanks, hope to hear soon from you are Siteground.


#4

Hello,

Siteground has installed it again and Still it is not working. I hired a developer that had made 1 site working. Bit the Other One Still not. We know that the fault is on SG site. Tuis is the message that my developer werkte to SG:
installing SSL using LetsEncrypt still doesnt work for that domain. I installed a certificate using https://www.sslforfree.com/ and then i uploaded by SSL/TLS method. But after i remove it and try the normal method, isnt working.
The real issue is why when certificate is installed, even if Magento has all settings done, the site doesnt go to https. It jumps back to http. And if i force it by htaccess, it give a redirection loop error.


#5

That won’t be an issue with the certificate, but with the way that Magento is detecting what scheme (http, https) is being used. Only your web developer (or something with admin access to your website) can help you with that.

Usually it’s done by tweaking the Base URL in Magento settings, but this depends on your specific site.


#6

Magento Base is set right, same as Other website. All configurations are set as same.
Now we asked SG to reload nginx. Becaise Other developer says that this can solve the issue


#7

Install of lets encrypt is not possible. Error messages. Support tells that its installed, they check on sslshopper. But on Siteground account it is not installed because it gives error. I have told them this several times. Can you please contact them and talk about it? I have now a huge list of tickets and all is waved away as its installed. But idd not


#8

My understanding from the other thread is that Siteground staff are already in touch with Let’s Encrypt staff, though I haven’t heard any updates about the status of the debugging process. If anyone from Siteground needs further information from this community, they’re certainly still welcome to join this forum and discuss the situation here.


#9

Thanks.

Got an question. When I check the certificate details I see that 1 site that works excellent is:
Domains:
*.uitverkoop.tips
uitverkoop.tips

But the one with the issue is:
Domains:
uitverkoopgigant.nl
www.uitverkoopgigant.nl

Does * can cause this issue?


#10

It’s true that the policies and procedures for issuing wildcard certificates are different from those for non-wildcard certificates, so that might be relevant to the problems that people are experiencing somehow.


#11

Issues are solved do i am really happy :smiley:


#12

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.