Issue Adding a New Certificate on ASUSTOR NAS

I am using ASUSTOR NAS as a web server. The following websites were hosted on it:

These websites had Let's Encrypt certificates installed through Asustor's control panel, and everything was working perfectly for years. I needed to add the following websites:


For these new websites, I wanted to add certificates. When I attempted to add a new certificate that would serve all the websites, I received a message stating that the certificate already exists. To overcome this, I deleted the existing certificates and tried to create new ones using the Certificate Manager in ADM 4.x.

Initially, I started receiving an error that "" is not valid and should be accessible through port 80. I tried replacing it with several other previously configured and working domains (,, ...), but the error persisted for each of them.

After multiple attempts, I am now getting the following error: "The number of certificates issued by Let's Encrypt for your domain name has reached its limit. (Ref. 5017)" and I can't do anything further.

I seek assistance to overcome this issue as the websites are live with high traffic, and now all of them display an error that the connection is not secure. Some of them cannot be accessed at all (You cannot visit right now because the website uses HSTS).

Please help me resolve this problem.

I don't see a reason for Let's Encrypt to deny issuance due to any limit. Sometimes there is a delay on the public logs but for now I don't see too many.

And, sometimes NAS devices have their own limit checks and this is possibly what is happening.

One likely problem is your is pointing to a different IP than all the others. If you keep retrying and failing Let's Encrypt will temporarily block you for an hour. The LE message in this case is not what your NAS is showing so hard to know for sure.

dig +noall +answer        239     IN      A

dig +noall +answer 300    IN      A
(all your other place domains match this one)

As an aside, your root domain seems to be a shared name with a large number of certs issued. And, LE has limits on how many certs it will issue per root domain. But, almost all the certs I saw were issued by cPanel so would not be a problem for LE. If more people using start using LE this could be problem that the owner of that domain would need to ask for a rate limit exclusion (or to be added to the public suffix list).


Thank you very much for the response.
I tried again, and now everything went smoothly. All websites are "alive" now.
You can close the ticket :slight_smile:

1 Like

You can close it by marking any thread as the solution (the checkmark icon on bottom of each post).

I see a new cert with 9 of your 10 names in first post. Just missing puzzle

Was trying to include puzzle on the cert when it had a different IP the original problem?


No, the issue was not with "puzzle," but I've decided that at this stage, we do not need a certificate for this domain.
Once again, thank you for your assistance.
Have a great and successful day!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.