IOS mail unable to verify newly issued certificate

My domain is:

I ran this command: Tried mail client on IOS 15

It produced this output: The client pops an untrusted certificate, claims it expired 09/29/21 12:21:40. I regenerated this certificate moments ago and it seems to be trusted in both regular browser as well as IOS safari browser. I double checked that both the browser and mail app is receiving the latest certificate. Seems like IOS mail client doesn't trust the new R3?

My web server is (include version):

The operating system my web server runs on is (include version): Ubuntu 18.04

My hosting provider, if applicable, is: AWS

I can login to a root shell on my machine (yes or no, or I don't know): Yes

The version of my client is: certbot 1.19.0

Your mail server isn't sending an intermediate certificate.


My mail server is courier, it uses concatenation of privacy and cert and it gets the latest version of both. I restart the server and I can verify the connection offers the newly generated cert. However the mail app won't trust it. Everything worked until the grand expiration today.

OK, I see what you mean, I changed it to include the full chain.pem rather than just the cert itself and now it's working fine.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.