Invalid Certificate


I am having windows 2012 r2 server (locally avaialble with me) with IIS running, server is having public IP, which is mentioned in a records of domain at godaddy
I am also having a domain (at godaddy) which is binding with global ip

site is working fine.

I installed SSL using win-acme.v2.1.16.1037.x64.trimmed

in IIS its showing as binding with my website, with hostname as above mentioned domain.
But when I access using https its gives error as Invalid Certificate.

some step is missing.
nothing has been done at domain from my site except IP mapping in A record
do I need to verify domain ownership if yes then How steps pls.

little urgent


1 Like

Hi @ritukamal

share a screenshot of your bindings menu and a screenshot of that specific https binding.

1 Like

1 Like

1 Like

There you see the missing step.

Check "Require Server Name Indication".

That's required that this binding is used.

1 Like


but still not working dear

1 Like

DONE and tried restarting IIS it gives following

Informations are required

1 Like

1 Like

1 Like

What says View (must show the certificate).

My browser sees a "Fortinet" certificate. May be Fortinet has added the certificate to that list.

Or you have another instance in front of your IIS, so that Fortinet-Instance answers.

1 Like

can u share what your browser is showing.


1 Like

1 Like

how can I check my SSL Certificate is installed properly on my windows 2012 server.

how to install Intermediate Certificates To Avoid SSL/TLS Not Trusted
on windows 2012 r2 server for letsencrypt ssl certificate installed using win-acme

my n/w is haivng fortinet firewall installed. do I need to do some settings in that also.

thanks dear .

Please read the output.

Your system shows a Fortinet certificate, you use Fortinet.

So you have to change or accept that.

How? I have no idea, I don't use such a fatal hacking tool, that intercepts man-in-the-middle certificates.

Looks not like a problem of your webserver, that's a problem you use Fortinet -->> remove that, change it or love it.

Check that your router or firewall is forwarding port 443 requests to your server, it looks like Fortinet is proxying the request instead.

That's expected if something like "Deep inspection" is used / checked.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.