Let's Encrypt on Windows 10 IIS

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: investor.octavehi.com

I ran this command: Followed the tutorial https://medium.com/beyond-the-helpdesk/lets-encrypt-for-windows-10-e07556c811b4

It produced this output: everything went as in article

My web server is (include version): IIS

The operating system my web server runs on is (include version): Windows 10 pro

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): I am an admin user on machine

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Everything went well, I have modified binding in IIS to use this certificate but browser says its invalid. Please help in resolving this.

Is there a question or problem?

Everything went well, I have modified binding in IIS to use this certificate but browser says its invalid

That name is using a cert for “secure.investor.octavehi.com”.
You should check the bindings in IIS (again).

1 Like

Hi @skasliwal

there is no certificate with that domain name. Older checks, ~~1,5 hours old - https://check-your-website.server-daten.de/?q=investor.octavehi.com#ct-logs

Issuer not before not after Domain names LE-Duplicate next LE
Let’s Encrypt Authority X3 2019-12-16 2020-03-15 secure.investor.octavehi.com - 1 entries duplicate nr. 1

There is only one certificate with one domain name.

But checking that domain there is no ip address:

Host T IP-Address is auth. ∑ Queries ∑ Timeout
secure.investor.octavehi.com Name Error yes 1 0
www.secure.investor.octavehi.com Name Error yes 1 0

The domain name isn’t defined. May be you have used dns validation to create the certificate.

So: What do you want to use? The secure subdomain or the investor.

investor requires a certificate with that domain name.

1 Like

Thanks for the input @JuergenAuer. I want the subdomain as investor. I want the certificate for investor.octavehi.com
Can you help me how should I do that?

Thanks for the input @JuergenAuer. I got the issue. I was using secure.investor.octavehi.com instead of actual domain hence this issue! Did this again without “secure” and worked for me.

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.