Internal server error when finalizing order

Hi, I have got an internal server error while polling the certificate:

{“type”:“urn:ietf:params:acme:error:serverInternal”,“detail”:“Error finalizing order”,“status”:500}

What is the recommended action in such case ? is retry will help here?

Its happen today when I tried order certificate for domain “422015.au-syd.e2e.certificate-manager.test.cloud.ibm.com

Thanks

1 Like

Difficult to say without more detail on the error…

But I can see that http is closed to that site (https is open):

curl -Iki http://422015.au-syd.e2e.certificate-manager.test.cloud.ibm.com/
curl: (7) Failed to connect to 422015.au-syd.e2e.certificate-manager.test.cloud.ibm.com port 80: Connection timed out

curl -Iki https://422015.au-syd.e2e.certificate-manager.test.cloud.ibm.com/
HTTP/1.1 200 OK
Date: Tue, 04 Feb 2020 12:47:14 GMT
Content-Type: text/html
Connection: keep-alive

Hi @cojalvo

a much more detailed log is required.

To see the commands that had worked. And the command with that answer.

Is not because of anything you did.

In many cases, it’s a load issue on the CA server (e.g. looking up your account’s records in the database).

Some things to check that can help:

  • Does it still happen if you try again shortly after?
  • Does it still happen if you use a fresh Issuer/ClusterIssuer?

If you are consistently getting the same error on every finalization attempt, then we can tag the staff to look into it, but otherwise I don’t think there’s much that can be done.

1 Like

Thanks for the help…it didn’t happen again, but I want to understand what should be the action in case it will happen again.
And if a retry may help here?

Yes, retry the finalization step. I’m not sure whether cert-manager will do that for you - it might be worth asking the project maintainers about it.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.