Internal Error when trying to use certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: tried to create certificate und

It produced this output:
warning Command failed: certbot certonly --config "/etc/letsencrypt.ini" --cert-name "npm-1" --agree-tos --authenticator webroot --email "xxxxxxxxxxxxx" --preferred-challenges "dns,http" --domains ""

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Some challenges have failed.

Ask for help or search for solutions at See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

My web server is (include version):

The operating system my web server runs on is (include version):
My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):
I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Welcome @Curtis777

There is no public DNS record for (is that the real name?). That is required for Let's Encrypt to find it.

I see your apex domain is managed by Cloudflare CDN. Are you trying to setup https between your origin server and the Cloudflare edge? If so, you should look at using an Origin CA from Cloudflare for that purpose.

If this is not helpful, please show the other error messages from certbot. Or, upload the /var/log/letsencrypt/letsencrypt.log file. Thanks


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.