Installing letsencrypt ssl using namecheap terminal

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain

I ran this --issue -d -w /home/weddhfsc/

It produced this output: Using CA: is using ZEROSSL as default CA now.
Please update your account with mean email aDD FIRST

My web server is (include version): Stellar Location

The operating system my web server runs on is (include version):litespeed

My hosting provider, if applicable, is:NAMECHEAP.COM

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): I'm using Terminal
the will install SSL cert on SSL on Control panel

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

You are using Zero SSL as your Certificate Authority. And, have a successful history with that (see here).

We help people use Let's Encrypt certificates. And, I'm not sure exactly what your problem is but you should ask Namecheap support or maybe see the Github for

Your domain server returns a cert for your hosting service so they are probably the best place to start.

The can be used to get Let's Encrypt certs. But, you need better instructions from namecheap to know how to use certs from anyone.


Namecheap is not supportive at all with LetsEncrypt and Zero SSL. I installed ZERO SSL before bec it offers SSL for free and I renew it every 3 mos, but now they set a limit on a domain and is forcing you to purchase their Basic Package of $10/mo which is way more expensive than other affordable SSL. So I tried installing letsencrypt but main prob that's appearing is I think that is reading that my site is under defaul SSL with zerossl even if right now I don't have any SSL on the site. I also deleted already my zerossl on my site but still when I checked folder it states that API is zerossl. I don't know if I can delete this or not. I asked support but they say that's it's out of their scope.

Well, I don't know why Let's Encrypt certs would work any better than the ones from ZeroSSL. We are not experts in namecheap configuration so is hard to give advice on what to do.

As for getting certs, you can add --server letsencrypt to the command to get certs from Let's Encrypt. You change the default Certificate Authority with: --set-default-ca --server letsencrypt

These are both in the docs for at their github


Do you have any more information about this limit? I've not heard of this before. Do you get a particular error message?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.