Installing Certbot in Ubuntu 14.0.4

Please fill out the fields below so we can help you better.

My domain is:

I ran this command:./letsencrypt-auto

It produced this output:

My web server is (include version):ubuntu14.04

The operating system my web server runs on is (include version):ubuntu

My hosting provider, if applicable, is:ali

I tried to install but could not install even though I used a lot of ways

root@iZwz9jayberwpx58w6qrbmZ:~/letsencrypt# pip -V
pip 9.0.1 from /usr/local/lib/python2.7/dist-packages (python 2.7)

Error pip is a problem, but my pip is 9.0 version

????? help
I can not install it

Hi, did you follow the instructions at or somewhere else? I’m going to guess somewhere else, as letsencrypt-auto has been replaced by certbot-auto for some time now.

If you follow the instructions at that site, you’ll get information on using an official PPA to get the certbot client. Alternately, you can still use certbot-autoby using the instructions here. I tested these on an Ubuntu 14.04 setup and they work great.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.