Problem when using ./certbot-auto


#1

Please fill out the fields below so we can help you better.

My domain is:yoursave.tk

I ran this command:./certbot-auto --apache -d yoursave.tk

It produced this output:
Details show in file: https://drive.google.com/open?id=0B3hbNSkef13hOGJpWDZMRTNrRXM
The last error message:
----------------------------------------
Command “/home/ubuntu/.local/share/letsencrypt/bin/python2.7 -u -c “import setuptools, tokenize;file=’/tmp/pip-build-hf1DvI/cryptography/setup.py’;exec(compile(getattr(tokenize, ‘open’, open)(file).read().replace(’
’, ‘
’), file, ‘exec’))” install --record /tmp/pip-G_84Nt-record/install-record.txt --single-version-externally-managed --compile --install-headers /home/ubuntu/.local/share/letsencrypt/include/site/python2.7/cryptography” failed with error code 1 in /tmp/pip-build-hf1DvI/cryptography
You are using pip version 8.0.3, however version 8.1.2 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.

My operating system is (include version): ubuntu 14.04

My web server is (include version):apache 2.4.7

My hosting provider, if applicable, is: aws

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):connected by ssh and run the command


#2

Do you know how much memory your system has? Some people using memory-constrained systems have had trouble in the past when compiling python-cryptography.


#3

My server’s memory is 1G.


#4

My server’s memory is 1G. And CPU 1G.


#5

As per Suddenly stopped running on Amazon Linux [solved], try

sudo /home/ec2-user/.local/share/letsencrypt/bin/pip install cryptography
sudo /home/ec2-user/.local/share/letsencrypt/bin/pip install interface
sudo /home/ec2-user/.local/share/letsencrypt/bin/pip install pyrfc3339
sudo /home/ec2-user/.local/share/letsencrypt/bin/pip install werkzeug
sudo /home/ec2-user/.local/share/letsencrypt/bin/pip install psutil

Check out the other thread for one other idea in the last post if this does not work.

:smiley:


#7

Thank your for answering my problem.
I have no letsencrypt in my server’s /home/ubuntu/share.
And I have installed pip in my server. pip version is 8.1.2(installed in /user/local/lib/python2.7/dist-packages)
So I used
sudo pip cryptography

But it returned some error

build/temp.linux-x86_64-2.7/_openssl.c:74705:5: error: (near initialization for ‘cffistruct_unions[133].size’)
In file included from /usr/include/sched.h:28:0,
from /usr/include/pthread.h:23,
from /usr/local/include/openssl/crypto.h:403,
from /usr/local/include/openssl/bio.h:20,
from /usr/local/include/openssl/asn1.h:16,
from build/temp.linux-x86_64-2.7/_openssl.c:445:
build/temp.linux-x86_64-2.7/_openssl.c:74705:45: error: initializer element is not constant
sizeof(X509_STORE_CTX), offsetof(struct cffialign__X509_STORE_CTX, y), 96, 10 },
^
build/temp.linux-x86_64-2.7/_openssl.c:74705:45: error: (near initialization for ‘cffistruct_unions[133].alignment’)
error: command ‘x86_64-linux-gnu-gcc’ failed with exit status 1


Command “/usr/bin/python -u -c “import setuptools, tokenize;file=’/tmp/pip-build-y1Waf0/cryptography/setup.py’;exec(compile(getattr(tokenize, ‘open’, open)(file).read().replace(’\r\n’, ‘\n’), file, ‘exec’))” install --record /tmp/pip-S0vEOs-record/install-record.txt --single-version-externally-managed --compile” failed with error code 1 in /tmp/pip-build-y1Waf0/cryptography/


#8

Is everything else uptodate on the server ?

sudo apt-get update;
sudo apt-get dist-upgrade;

I don’t use AWS, and whilst I know it has a few specific characteristics, I’m not familiar with them.

If no-one comes along with an answer ( hopefully they will) it may be worth looking at some of the alternate clients. Certainly the Bash ones have a lot less dependencies that the official client, so may be a solution around the issue.


#9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.