Certbot Error Install Error

When i will install Certbot come this: https://hasteb.in/aludimuy.sql

I use Ubuntu 18.04 with nginx

How did you install Certbot? Did you follow the instructions here https://certbot.eff.org/lets-encrypt/ubuntubionic-nginx?

Certbot on Ubuntu 18.04 (using the above instructions) should be using Python 3.

If you installed Certbot using some other method, I can suggest removing it and following the link above.

I used this https://www.digitalocean.com/community/tutorials/how-to-secure-nginx-with-let-s-encrypt-on-ubuntu-18-04

How can i reinstall this?

Those instructions are okay as well.

I think what happened is that at some point you tried to install Certbot from pip, which has resulted in Python conflicts on your system.

If you run the version of Certbot you got from the PPA (rather than the one from pip in /usr/local/bin), do you still get the error?

/usr/bin/certbot --nginx -d system.h4yfm.eu
1 Like

It worked thank you!!!

For a more permanent fix, you can rename /usr/local/bin/certbot to something else, so it does not interfere with your working Certbot installation.