Installed Certbot but HTTPS does not work

My domain is:

I ran this command: certbot --nginx

It produced the output where it stated that everything is ok. Then I removed the "Error 404" for HTTP (port 80) server directive. Before I ran certbot, was not accessible from HTTP.

My web server is (include version): nginx/1.14.2

The operating system my web server runs on is (include version): Debian 10

My hosting provider, if applicable, is: VPS

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a console.

The version of my client is (output of certbot --version): 1.16.0

1 Like

Hi @kekc_leader,

It looks like you have a firewall that is blocking incoming connections on port 443 (HTTPS), while allowing them on port 80 (HTTP).

1 Like

Thank you! That was indeed the root of the issue.
I've run the following command as root and it fixed it:
ufw allow https


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.