Install fails on Leap 42.1


#1

./letsencrypt-auto --help

Bootstrapping dependencies for openSUSE-based OSes…

The following 3 NEW packages are going to be installed:
libffi-devel-gcc5 python-setuptools python-virtualenv

3 new packages to install.
Overall download size: 1.9 MiB. Already cached: 0 B. After the operation, additional 3.1 MiB will be used.
Continue? [y/n/? shows all options] (y): y

Checking for new version…
Traceback (most recent call last):
File “/tmp/tmp.RzWpRHMNhB/fetch.py”, line 20, in
from urllib2 import build_opener, HTTPHandler, HTTPSHandler, HTTPError
ImportError: cannot import name HTTPSHandler


#2

Try my client: https://github.com/Neilpang/le.git

support OpenSUSE.