Incorrect URL for renewal verification


#1

Hi Everybody,

I am trying to renew my first certificates, but I am constantly facing the following issue: the certbot tries to open a not existing url:

I got my certificates with the following command:
“sudo certbot certonly --webroot /var/www/html/webmail -d webmail.lpokoradi.com

This was working perfectly, at least I got the certifications.

Now I would like to renew the certification with the following command:

“sudo certbot renew”

But I got the following error message:

Cert is due for renewal, auto-renewing…
Plugins selected: Authenticator webroot, Installer None
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for webmail.lpokoradi.com
Waiting for verification…
Cleaning up challenges
Attempting to renew cert (webmail.lpokoradi.com) from /etc/letsencrypt/renewal/webmail.lpokoradi.com.conf produced an unexpected error: Failed authorization procedure. webmail.lpokoradi.com (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching https://webmail.lpokoradi.com.well-known/acme-challenge/FUycnH5Tdiby4HXedBqg8A97qQZ5TGVTBgTBB1OT1_k: Error getting validation data. Skipping.

The interesting thing is that the url is: https://webmail.lpokoradi.com.well-known/acme-challenge… with a missing / sign between my domain and the .well-known folder.

Have you faced this issue before? How could it be resolved?

Thanks for your help!

Further details:

The operating system my web server runs on is (include version): Ubuntu Server 18.04.1

I can log in to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

I have another domain with a similar problem, but if this one is solved, hopefully the other will be resolved as well.


#2

Hi @lpokoradi,

Can you share your webserver’s configuration? This is almost always caused by a redirect rule in the webserver configuration that is malformed and drops the /.


#3

Hi @cpu,

Sorry, I am not sharing it. :wink: Because it seems you were totally right. I have a redirection in my apache config, and my url was “incorrect”. The incorrect settings was:

RedirectPermanent / https://webmail.lpokoradi.com

Now it is working with the following:

RedirectPermanent / https://webmail.lpokoradi.com/

Thanks again! It was a quick solution!


#4

:tada: Glad to hear you were able to resolve the problem!