ImportError: no Modul named datetime after updating Server to Xenial 16.04


#1

Hi,
after Upgrading my Server to Ubuntu 16.04 and struggle with renew certifactes via cron i tried via command line today and this gave me this error.

Updating letsencrypt and virtual environment dependencies...Traceback (most recent call last):
  File "/root/.local/share/letsencrypt/bin/pip", line 7, in <module>
    from pip import main
  File "/root/.local/share/letsencrypt/local/lib/python2.7/site-packages/pip/__init__.py", line 14, in <module>
    from pip.utils import get_installed_distributions, get_prog
  File "/root/.local/share/letsencrypt/local/lib/python2.7/site-packages/pip/utils/__init__.py", line 27, in <module>
    from pip._vendor import pkg_resources
  File "/root/.local/share/letsencrypt/local/lib/python2.7/site-packages/pip/_vendor/pkg_resources/__init__.py", line 34, in <module>
    import plistlib
  File "/usr/lib/python2.7/plistlib.py", line 62, in <module>
    import datetime
ImportError: No module named datetime

Have anyone a glue how to fix this?


#2

this Fixed it! Can't use letsencrypt-auto: ImportError: No module named _io


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.