Idna and cryptography issues


Very recently i started getting such messages, when certbot is freshly installed and while trying to obtain a certificate.
If the certbot --apache command is run, it results in following error.
An unexpected error occurred: ContextualVersionConflict: (idna 2.8 (/usr/lib/python2.7/dist-packages), Requirement.parse('idna<2.8,>=2.5'), set(['requests']))

So idna installed is 2.8, but certbot requires version less than that?
Ravi Kumar



You’ve encountered an issue that’s been discovered by certbot team.

It looks like " requests " are looking for a version of IDNA lower than 2.8.

Thank you


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.