I was following this guide: How to stop using TLS-SNI-01 with Certbot
in order to update my ACME client and in the guide it mentions if the version of certbot is below 0.28 than you need to upgrade it with a link to the website: https://certbot.eff.org/lets-encrypt/ubuntuxenial-nginx
So essentially I was following this guide to update my certbot and now when I run any Certbot command I get a ContextualVersionConflict and I have no idea what to do.
My domain is: hveachat.com
I ran this command: certbot
It produced this output: ContextualVersionConflict: (pyasn1 0.1.9 (/usr/lib/python2.7/dist-packages), Requirement.parse(‘pyasn1<0.5.0,>=0.4.1’), set([‘pyasn1-modules’]))
Please see the logfile ‘/tmp/tmpV5lI1x’ for more details.
Ubuntu 16.04, nginx.
The version of my client is (e.g. output of
certbot --version or
certbot-auto --version if you’re using Certbot): it was 0.17.0