pkg_resources.ContextualVersionConflict jmespath 1.0.0

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:filupmarley.com

I ran this command: certbot --version

It produced this output: An unexpected error occurred:
pkg_resources.ContextualVersionConflict: (jmespath 1.0.0 (/usr/local/lib/python3.8/site-packages), Requirement.parse('jmespath<1.0.0,>=0.7.1'), {'boto3'})

My web server is (include version): nginx reverse proxy nginx-1.22.0_4,2,

The operating system my web server runs on is (include version): Truenas Freebsd 13.1

My hosting provider, if applicable, is: Self

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): py38-certbot-1.27.0,1

I have a wildcard cert for *.filupmarley.com. Cron job updates cert every 90 days. I use the py38-certbot-dns-route53-1.27.0 plugin.

The last few weeks this error has come up: pkg_resources.ContextualVersionConflict: (jmespath 1.0.0 (/usr/local/lib/python3.8/site-packages), Requirement.parse('jmespath<1.0.0,>=0.7.1'), {'boto3'})

It looks like you've installed Certbot using pip globally, which is not recommended. Using pip globally is dreadful when it comes to dependencies.

Please install Certbot in a virtual environment as instructed in the Certbot installation guide for nginx+pip: Certbot Instructions | Certbot

Or even better, use the snap version if possible.

3 Likes

Thanks Osiris. I will take a look at that.

1 Like