Icewarp mail server, cannot get initial cert

Hello Everyone,

I just updated to the latest version of Icewarp mail server, and I would like to use Let’s Encrypt. The request mechanism is built into the mail server software, so I do not have any options other than domain and submit. I do have port 80 open to the mail server, and I can see a request go out in the logs, but I don’t think I am ever getting anything as return.

When you request the certificate it says it will turn green when it is issued. Is this a 5 min thing, or a 5 hour thing?

The domain is, and the mail server I am trying to get a certificate for in

Any help would be appreciated, I feel like I am missing something simple.


1 Like

OK, update.

I think the certificate issued. If I go to the it seems to have worked, but I show nothing in the mail server console that the certificate was issues, and nothing for expiration date. I guess I have to call Icewarp.

I think it might need a restart or some more clicks…
This is the cert in use on port 25 and port 110:


1 Like

I just wiped out all the certificates.

Icewarp was not updating status in the console window. So I tried a whole lot of times and ended up with like 30 certificates.

I should have it all fixed in a few.

I think hit the rating limit on some of the domains, like, because I can’t reissue for that one. The other domains, like worked fine. I’ll try securing the rest in a day or so.

1 Like


checking your domain you have created two new certificates. And you use one of these.

But your server has a wrong chain, the intermediate certificate is sent twice.

And where are your mail ports?

Only the (not so good) Ports 25, 110 + 143 are open, that allows unencrypted traffic. 25 SMTP open 220 ESMTP SuperMultiMail v1.; Fri, 13 Dec 2019 02:40:56 -0500 53 DNS open 110 POP3 open +OK SuperMultiMail v1. POP3 Fri, 13 Dec 2019 02:40:51 -0500 143 IMAP open * OK SuperMultiMail v1. IMAP4rev1 Fri, 13 Dec 2019 02:40:51 -0500

The encrypted ports 465, 993 and 995 should be listet under "connections".

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.