I reset my server with ssl certificate on this

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: danstoncubemc.com

I ran this command: I just reset my dedicated server

It produced this output: No command ran

My web server is (include version): OVH dedicated server with apache2, php7, mysql8

The operating system my web server runs on is (include version): Debian 10 Buster

My hosting provider, if applicable, is: OVH

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): No version because my server were reset

Hello, I've reset my server because I buy a new server for cross my old web server but I forgot I got ssl certificate on him. I used certbot for applied certificate.
How can I do for applied a SSL certificate on a new server ?
Also, I make too much try on my new dedicated server (another one) and I reach the limit of letsencrypt.

Kinds regards

Then you'll need to wait for the limit to expire. See:

I can't then give me a error : Somes challenges have failed.
I'm unauthorized to do that on a new server because I doesn't revoke the old ssl certificate, I reset entire of my server. A complete reinstallation.

Revoking won't change anything - please don't revoke certs needlessly.

Please show the complete error message (or log file).

Please show the output of:
sudo apachectl -t -D DUMP_VHOSTS

You need a functional HTTP web site before trying to secure it (via HTTP authentication).
Create an HTTP vhost config for "site.danstoncubemc.com" first.
One that uses a DocumentRoot that matches the --webroot used (at least for the challenge requests).

I create an HTTP vhost config for danstoncubemc.com.
I remake the manipulation for certificate with certbot and I got this :

Please show the vhost file.
And also reshow:

And also show the full command used to get that last error message.

[the less you show the longer this takes]

1 Like

I hope it's good.

*:80 is a NameVirtualHost

default server danstoncubemc.com (/etc/apache2/site-enabled/00-default.conf:1)
port 80 namevhost danstoncubemc.com (etc/apache2/sites-enabled/000-default.conf:1)
port 80 namevhost danstoncubemc.com (etc/apache2/sites-enabled/danstoncubemc.com.conf:1)

And I ran the command :
sudo certbot certonly --webroot

Sorry to give so little information, I’m starting a little bit on requests for help. Thank you for the time you take to answer me. I hope we find the solution!

1 Like

There is a name:port conflict between those two files.

This command is also out of order.
sudo certbot certonly --webroot -w /var/www/site -d danstoncubemc.com

[and why using certonly now?]

What can I do ? Sorry I'm a beginner on that.
Thanks again for the help.

1 Like

Please show file:

1 Like

No problem sir

Please add a line to that file:
ServerName localhost
Disable the file - if not needed.

Then restart Apache.

I add ServerName localhost in the categorie VirtualHost, not Directory and I restart apache. I retry the certification and it doesn't work again.
The sudo apachectl -t -D DUMP_VHOSTS show this :

This vhost dump is now good :slight_smile:
Please show the command you ran that failed.
Please also show file:
[or upload it here if it is too long]

Nice !
I ran this command : sudo certbot certonly --webroot -w /var/www/site -d danstoncubemc.com
Processing: letsencrypt.log...
Processing: letsencrypt.txt.log...

I make a pastbin, that was too long : 2021-09-17 19:29:09,647:DEBUG:urllib3.connectionpool:http://localhost:None "GET - Pastebin.com