I Have a problem on VESTACP - (Error: SSL=no doesn't exist)


#1

I’m using CentOS 7.2. I followed all the steps of github:

Please help!


#2

Please complete the initial questions


My domain is:

I ran this command:

It produced this output:

My operating system is (include version): Centos 7.2.1

My web server is (include version):
My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or n, or I don’t know):
I’m using a control panel to manage my site (no,or provide the name and version of the control panel):



#3

My domain is: inemcode.com
I run this command: letsencrypt-vesta mateo inemcode.com

The operating system is CentOs 7.2, I have a VPS in DigitalOcean and I’m using VESTACP in its latest version.

Greats, pleas help!


#4

What was the output / response to the command ?


#5

It was the only error: (Error: SSL=no doesn’t exist)


#6

You got that error on the command line ? directly after your command “letsencrypt-vesta mateo inemcode.com” ?


#7

This is what came out:

[root@mail local]# letsencrypt-vesta admin cobrawarez.com
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Starting new HTTPS connection (1): acme-v01.api.letsencrypt.org
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for cobrawarez.com
http-01 challenge for www.cobrawarez.com
Using the webroot path /etc/letsencrypt/webroot for all unmatched domains.
Waiting for verification…
Cleaning up challenges
Generating key (2048 bits): /etc/letsencrypt/keys/0003_key-certbot.pem
Creating CSR: /etc/letsencrypt/csr/0003_csr-certbot.pem

IMPORTANT NOTES:

  • Congratulations! Your certificate and chain have been saved at
    /etc/letsencrypt/live/cobrawarez.com/fullchain.pem. Your
    cert will expire on 2017-03-05. To obtain a new or tweaked version
    of this certificate in the future, simply run certbot-auto again.
    To non-interactively renew all of your certificates, run
    "certbot-auto renew"

  • If you like Certbot, please consider supporting our work by:

    Donating to ISRG / Let’s Encrypt: https://letsencrypt.org/donate
    Donating to EFF: https://eff.org/donate-le

Error: SSL=no doesn’t exist
Redirecting to /bin/systemctl reload httpd.service
Redirecting to /bin/systemctl reload nginx.service
[root@mail local]#

In VESTACP: “Código de Error:”


#8

OK, do this successfully obtained a certificate for cobrawarez.com (different from the domain you said above). The problem is not with obtainint the certificate, rather with installing it into your vestaCP.

Due to where the issue is, you should really open an issue with the author of this VestaCP plugin at https://github.com/interbrite/letsencrypt-vesta/issues

In addition, you could potentially manually install the certificate you have obtained into VetsaCP and configure it.


#9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.