I get rerouts to root after instaling cerbot

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: homeprostoronto.com

I ran this command: sudo certbot --apache -d homeprostoronto.com

It produced this output: when i try to go to the website or try to go to wp-admin i always get redirected to root

My web server is (include version): digitalocean

The operating system my web server runs on is (include version):ubuntu 18.04

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): i not sure i just installed it today and updated it

please help me im really new to this.

I get rerouts to root after instaling cerbot

You may have multiple redirects - and some may not be doing what you expected.

I see:

curl -Iki http://homeprostoronto.com/
HTTP/1.1 301 Moved Permanently
Date: Mon, 23 Mar 2020 20:05:33 GMT
Content-Type: text/html; charset=iso-8859-1
Connection: keep-alive
Set-Cookie: __cfduid=d8608b05ad21cabe7370b87bff4dd33651584993933; expires=Wed, 22-Apr-20 20:05:33 GMT; path=/; domain=.homeprostoronto.com; HttpOnly; SameSite=Lax
Location: https://root/
CF-Cache-Status: DYNAMIC
Server: cloudflare
CF-RAY: 578ac4955c70e968-MIA

Hi @Xunne

there is a check of your domain, ~~50 minutes old - https://check-your-website.server-daten.de/?q=homeprostoronto.com

Why are there such curious redirects?

Domainname Http-Status redirect Sec. G
http://homeprostoronto.com/
104.18.62.87 301 https://root/
Html is minified: 100,00 % 0.187 E

And you have created some certificates:

Issuer not before not after Domain names LE-Duplicate next LE
Let’s Encrypt Authority X3 2020-03-23 2020-06-21 homeprostoronto.com - 1 entries duplicate nr. 1
Let’s Encrypt Authority X3 2020-03-20 2020-06-18 homeprostoronto.com, www.homeprostoronto.com - 2 entries duplicate nr. 1
CloudFlare Inc ECC CA-2 2020-03-20 2020-10-09 *.homeprostoronto.com, homeprostoronto.com, sni.cloudflaressl.com - 3 entries
Let’s Encrypt Authority X3 2020-02-20 2020-05-20 homeprostoronto.com, www.homeprostoronto.com - 2 entries

Use that from 2020-03-20.

It’s better to disable Cloudflare if your configuration is buggy.

PS: What says

apachectl -S

Hello thank you for the reply, i was originally using cloudflare, but i was having trouble getting the ssl to work when i update the url on my website it always doesn’t work, so i decided to try certbot witout removing cloudflare first, then i made a mistake at first putting my url, then i re did it, then afterward when i tried to visit my site i got rerouted to root co i deleted the certificate but im still getting same issue

You have broken your configuration by deleting a certificate that was still in use.
You may be able to fix this inconsistency by (re)moving or disabling the file/site:
/etc/apache2/sites-enabled/000-default-le-ssl.conf
Then try again:
apachectl -S

thank you, how do i disable it? im a real noob for this and its really my first doing it on this website, and again thank you

hello i was able to remove it but still getting the same issue

That is not the same issue, it no longer fails as before:

So you are making progress.

but what do i do tried allot things but it still the same issue, do still need to check for certificates or i need to fing a place that i need to change for it to work?

You probably need to get a new certificate (since you deleted the last).
You can check if you have any certificates with (one of):
certbot certificates
or
certbot-auto certificates

hi
yest thankyou again yup i created a new certificate, but im still being routed to root instead of my website, any advice you can give me?

Go step by step.
Don’t assume anything works until you have checked it.

Hello,
thank you again for the advice, so i removed cloudfire, i redid the ssl certificate I am able to get to the website now with https it always redirects me to the to the IP address, my problem now is that i cant still access wp-admin, any suggestion for that? oh and i still get redirected to root when using http

Search through the configs for any redirects.
Check any .htaccess files for redirects.
Verify which system/software is sending the redirection.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.